题目1010:A + B

题目描述:
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
输入:
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
输出:
对每个测试用例输出1行,即A+B的值.
样例输入:
one + two =
three four + five six =
zero seven + eight nine =
zero + zero =
样例输出:
3
90
96
来源:

2005年浙江大学计算机及软件工程研究生机试真题


代码:

#include <iostream>
#include <string.h>
using namespace std;
char strNum[10];
char * nums[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
const char * el = "=";
const char * add = "+";
int getNum(const char * str){
    for(int i = 0 ; i < 10;i++){
        if(strcmp(str,nums[i])==0)return i;
    }
    return -1;
}
int main()
{
    int a=0,b=0,tag=0;
    while(1){
        cin>>strNum;
        int t = getNum(strNum);
        if(t!=-1&&tag==0){
            a*=10;
            a+=t;
        }else if(t!=-1&&tag!=0){
            b*=10;
            b+=t;
        }else if(strcmp(add,strNum)==0){
            tag = 1;
        }else if(strcmp(el,strNum)==0){
            if(a==0&&b==0)break;
            cout<<a+b<<endl;
            a=0;b=0;tag=0;
        }
    }
    return 0;
}
 
/**************************************************************
    Problem: 1010
    User: 小qixuan
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1520 kb
****************************************************************/



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值