ZOJ Talented Chef

C题目传送门:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5265


Time Limit: 2 Seconds       Memory Limit: 65536 KB

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= NM <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input
2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10
Sample Output
3
10


找一下规律可以看出,当n<=m 时是全部每次都取1的,这是次数即是最大值maxs。

当n>m时有sums%m!=0需要向上取整,此时因为次数最少不能比最大值小,输入maxs。否则取除就可以了。


#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

const int inf=2<<30;

int main(){
    int cas;
    scanf("%d",&cas);
    while(cas--){
        int n,m;
        scanf("%d%d",&n,&m);
        int x,maxs=-1*inf;
        int sums=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            sums+=x;
            maxs=max(maxs,x);
        }
        if(n<=m){
            printf("%d\n",maxs);
            continue;
        }
        int ans=(sums)/m;
        //向上取整
        if(sums%m!=0) ans++;
        if(ans>=maxs) printf("%d\n",ans);
        else printf("%d\n",maxs);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值