poj3254 Corn Fields (状态压缩dp)

Corn Fields
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M  and  N  
Lines 2.. M +1: Line  i +1 describes row  i  of the pasture with  N  space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

        
        
2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
         
         
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:
给出一个10矩阵  从中取有限个1  求没有上下左右没有相邻1的排列总数

解题思路:
1 先把每一排可以满足要求的排列情况枚举出来
2从题目给的每一行里面挑一种可以的情况 再从上一行挑一种可以的情况  要两行加起来也可以 
3dp[i][state]=dp[i][state'] state'是所有满足state上一行的排列 总数全部加起来 最后得到答案
4注意位运算

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int p,q,sum,pq[20],can[1<<12],dp[20][1<<12];
int main()
{
    int i,j,k,l,a;
    while(~scanf("%d%d",&p,&q))
    {
        memset(pq,0,sizeof(pq));
        memset(can,0,sizeof(can));
        memset(dp,0,sizeof(dp));
        for(i=0;i<p;i++)//把每一行读的数取反存在pq里 那么pq[i]=1的时候下一行的i位置才能取1 pq[i]=0时下一行只能取0
            for(j=0;j<q;j++)
            {
                scanf("%d",&a);
                if(!a) pq[i]+=(1<<(q-j-1));
            }
        for(i=0,j=0;i<(1<<q);i++)//用can存 在一行全部为1中挑选出 所有没有相邻1的排列情况
            if((i&(i<<1))==0) can[j++]=i;//j最后的值就是一共有多少种排列数
        for(i=0;i<j;i++)
            if((pq[0]&can[i])==0) dp[0][i]=1;
        //初始化dp[0] can[]其实是作为对照 后面符合的情况都是从这里挑出来再比较可不可以
        for(i=1;i<p;i++)
            for(k=0;k<j;k++)
                if((pq[i]&can[k])==0)//以can做对照 挑一个可以的pq排列
                    for(l=0;l<j;l++)//再挑一个可以的can排列
                        if((pq[i-1]&can[l])==0&& (can[k]&can[l])==0)//这一排跟上一排不冲突就符合
                            dp[i][k]=(dp[i][k]+dp[i-1][l])%100000000;//题目要求输出mod100000000的值
        for(i=0,sum=0;i<j;i++)
            sum+=dp[p-1][i];
        printf("%d\n",sum%100000000);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值