hdu-2138- How many prime numbers

9 篇文章 0 订阅
Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
  
  
3 2 3 4
 

Sample Output
  
  
2
 

意思就是说给了多组数字,每组都有很多数字,让你判断每组里的素数有多少个,方法很简单,不过不管是用c还是java,貌似都是用sqrt函数比较快些,大概就是这样,具体代码如下

import java.io.*;
import java.util.*;
import java.math.*;
public class Main
{
    public static void main(String[] args)
    {
        Scanner cin=new Scanner(new BufferedInputStream(System.in));
        int num,sum,n;
        boolean isprime;
        while(cin.hasNext())
        {
            num=cin.nextInt();
            sum=0;
            for(int i=1;i<=num;++i)
            {
                n=cin.nextInt();
                if(n==1)    continue;
                if(n<4)
                {
                    ++sum;
                    continue;
                }
                isprime=true;
                double tem=Math.sqrt(n);
                for(int j=2;j<=tem;++j)
                {
                    if(n%j==0)
                    {
                        isprime=false;
                        break;
                    }
                }
                if(isprime)    ++sum;
            }
            System.out.println(sum);
        }
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值