Description
Input
Output
一个数表示最小代价
Sample Input
3 3
1 2 3
1 2 21
1 3 21
2 3 22
Sample Output
34
Solution
既然它要你有且仅有一条路,那就是显然的最小生成树。
因为最后的代价是与边的数量有关的,那就直接把发达程度算在每条边的权值里就行了,具体看一下我的代码
另外
我想借这题说一下程序并查集最简单的方法
int getfather(int x){
return fa[x]==0?x:fa[x]=gf(fa[x]);
}
Code
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 101000
#define fo(i,a,b) for(int i=a;i<=b;i++)
using namespace std;
int n,m,fa[N],b[N];
struct note{
int x,y,z;
};
note a[N];
bool cnt(note x,note y){return x.z<y.z;}
int gf(int x)
{
return fa[x]==0?x:fa[x]=gf(fa[x]);
}
int main()
{
scanf("%d%d",&n,&m);
fo(i,1,n) scanf("%d",&b[i]);
fo(i,1,m) scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].z),a[i].z=a[i].z-b[a[i].x]-b[a[i].y];
sort(a+1,a+m+1,cnt);int ans=0;
fo(i,1,m)
{
int x=gf(a[i].x),y=gf(a[i].y);
if(x!=y) {
ans+=a[i].z;fa[x]=y;
}
}
printf("%d",ans);
}