POJ 1860 Currency Exchange 贝尔曼-福特算法(Bellman-Ford)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16723 Accepted: 5856

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
 
这道题我只想说,各种无情与各种的坑,已经无力吐槽了,但是依然还是AC了,这道题具体可以选择Bellman-Ford算法,这个算法本身是求最短路径的,但是在这道题中,负权环的利用对求解这道题灰常有帮助,我们可以把每一种币种当成是图论中的一个点,然后之间的汇率以及汇费计算结果当成之间的边的权值,然后求自己所拥有的货币经过一系列兑换,直到兑换回原来货币的时候是否可以增长,这道题解题就是运用Bellman-Ford算法求最长路程,其实就是判定这个图中是否有一条负权环,即一条环,可无限增加Nick手中的钱数,只要任意存在一条这样的环,则Nick手中的钱可以增长,否则不可以。这样的情况下就可以AC了,之后我在做题时候发现,如果把数组定义为题目中所说的100稍大的105时,题目会报Runtime Error,对此我很无语,把105改成256,结果就AC了,这是一个巨坑的点,给的数据超出了他所限定的数据范围!!!

下面是AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
double num,rate[256][256],com[256][256];
int m,n,fi;
struct Edge{
    int u, v;    
    double com,rate;  
}edge[256];
double dist[256];
void relax(int u, int v, double rate, double com)
{
    if(dist[v] < ( dist[u] - com ) * rate && dist[u] > com)
        dist[v] = ( dist[u] - com ) * rate;
}
bool Bellman_Ford()
{
	int i;
	for(i=1;i<=n;i++)
		dist[i]=0;
	dist[fi]=num;
    for(i=1; i<=n-1; ++i)
        for(int j=1; j<=2*m; ++j)
            relax(edge[j].u, edge[j].v, edge[j].rate, edge[j].com);
    bool flag = 1;
        for(i=1; i<=2*m; ++i)
        if(dist[edge[i].v] < ( dist[edge[i].u] - edge[i].com ) * edge[i].rate )
        {
            flag = 0;
            break;
        }
    return flag;
}
int main()
{
	int i,a,b;
	while(scanf("%d%d%d%lf",&n,&m,&fi,&num)!=EOF)
	{
	memset(rate,0,sizeof(rate));
	memset(com,0,sizeof(com));
	for(i=1;i<=2*m;i+=2)
	{
		scanf("%d%d",&a,&b);
		edge[i].u=a;
		edge[i].v=b;
		edge[i+1].u=b;
		edge[i+1].v=a;
		cin>>edge[i].rate>>edge[i].com>>edge[i+1].rate>>edge[i+1].com;
	}
	if(Bellman_Ford()==0)
		printf("YES\n");
	else
		printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值