POJ 1125 Stockbroker Grapevine 图论 Floyd-Washall算法

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23914 Accepted: 13143

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
 
这道题个人感觉英文部分比ACM部分难,看的纠结死了,但是一理解题意,发现题目其实是最基础,最简单的图论题,题目意思就是,有个人,唯恐股票市场不乱,然后给股票投资人一些假情报,造成每个人疯狂,然后,这些股票投资人也不是吃干饭的,他们只相信一部分自己相信的其他股票投资人的信息,并且他们花一定时间会让这个股票投资人相信自己的假情报,现在求这个谁先知道这个假情报会使用最短时间,让其他所有投资者相信这个假情报呢???如果不能让所有人相信,输出“disjoint”。这个题解法我想的还是Floyd-Washall算法求出全源最短路径,每个股票投资人是之间的一个点,然后从相信的股票投资人那里获取消息就是路径,权值为消息传播时间,先将所有路径的距离定义为最大,然后建立图,并且带入Floyd-Washall算法模板计算出任意两个股票投资人之间传播消息的最短时间,之后计算一个人到其他所有人中传播最短时间的最大值,这个值就是这个人把信息传播给其他所有人的最小值,然后将所有人传播时间的最小值中继续取最小值,即为这个消息传播到每一个人所需要的最小时间,如果这个时间大于初始化的极大值,则证明消息无法传达给所有人,输出“disjoint”,否则,输出第一个传播人以及最小时间,此题就可以AC了。
 
下面是AC代码:
 
#include<cstdio>
#include<iostream>
using namespace std;
int D[105][105],G[105][105];
void Floyd_Washall(int n)
{
    int i,j,k;
    for (i=1;i<=n;i++)
        for (j=1;j<=n;j++)
			D[i][j]=G[i][j];
    for (i=1;i<=n;i++) { D[i][i]=0; }
    for (k=1;k<=n;k++)
        for (i=1;i<=n;i++)
            for (j=1;j<=n;j++)
                if (i!=j&&D[i][j]>D[i][k]+D[k][j])
                      D[i][j]=D[i][k]+D[k][j];
}
int main()
{
	int i,j,n,m,a,b,max,min,pmin;
	while(1)
	{
		scanf("%d",&n);
		if(n==0)
			break;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				G[i][j]=1000;
		for(i=1;i<=n;i++)
		{
			cin>>m;
			for(j=1;j<=m;j++)
			{
				cin>>a>>b;
				G[i][a]=b;
			}
		}
		Floyd_Washall(n);
		min=1000;
		for(i=1;i<=n;i++)
		{
			max=0;
			for(j=1;j<=n;j++)
			{
				if(max<D[i][j]&&i!=j)
					max=D[i][j];
			}
			if(min>max)
			{
				min=max;
				pmin=i;
			}
		}
		if(min<1000)
			printf("%d %d\n",pmin,min);
		else
			printf("disjoint\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值