Power Crisis

Problem Description

During the power crisis in New Zealand this winter (caused by a shortage of rain and hence low levels in the hydro dams), a contingency scheme was developed to turn off the power to areas of the country in a systematic,
totally fair, manner. The country was divided up into N regions (Auckland was region number 1, and Wellington number 13). A number, m, would be picked `at random', and the power would first be turned off in region 1
(clearly the fairest starting point) and then in every m'th region after that, wrapping around to 1 after N, and ignoring regions already turned off. For example, if N = 17 and m = 5, power would be turned off to the
regions in the order:1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7. The problem is that it is clearly fairest to turn off Wellington last (after all, that is where the Electricity headquarters are), so for a given
N, the `random' number m needs to be carefully chosen so that region 13 is the last region selected. 
Write a program that will read in the number of regions and then determine
the smallest number m that will ensure that Wellington (region 13) can function while the rest of the country is blacked out.

Input

Input will consist of a series of lines, each line containing the number of regions (N) with . The file will be terminated by a line consisting of a single 0.

Output

Output will consist of a series of lines, one for each line of the input. Each line will consist of the number m according to the above scheme.

Sample Input

17
0

Sample Output

7
 
 
 //     题意:给定一个N,每隔M个数删除一个,最后一个数是13,求M的值。
 
 
//标程:
#include<list>
#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
	//freopen("a.txt","r",stdin);
    list<int> l;
    list<int> ::iterator it1,it2,it3;
    int i,j,k,n;
    while(scanf("%d",&n),n)
    {
      for(i=1;;i++)
      {   l.clear();
          k=0;
          for(j=1;j<=n;j++) l.push_back(j); 
          it1=l.begin();
          while(l.size()>1)
          {  it2=it1; it1++;
            if(it1==l.end()) it1=l.begin();
            l.erase(it2);
            k=(i-1)%l.size();
            while(k--)
            {    it1++;
                if(it1==l.end()) it1=l.begin();
            }
          }
         if(l.front()==13) {cout<<i<<endl; break;}
      }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值