Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
Output
For each test case, output one line contains the shorest possible complete text.
Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
Sample Output
abcdabcd
qwertabcde
/*题意:
首先有一个字母的转换表,就是输入的第一行的字符串s1,它们对应着一种映射关系,'a'-s1[0],'b'-s1[1],......
然后下面一个字符串是密文+明文的形式的字符串。其中明文可能是不完全的.(abcdab的明文是ab).
*/
//标程:
#include<cstdio>
#include<cstring>
using namespace std;
char s1[26], s2[100011];
int main()
{
// freopen("a.txt","r",stdin);
int n, len, i, j, k, flag, temp;
while(scanf("%d",&n)!=EOF)
{
memset(s1,0,sizeof(s1));
memset(s2,0,sizeof(s2));
getchar();
while(n--)
{
scanf("%s",s1);
scanf("%s",s2);
len=strlen(s2);
j = 0;
temp = (len+1)/2;
for(i=temp;i<len;i++)
{
if(s1[s2[i]-'a']!=s2[j]) continue;
else
{
flag=0;
j ++;
for(k=i+1;k<len;k++)
if(s1[s2[k]-'a']!=s2[j++])
{
flag=1;
break;
}
if(flag==0) break;
}
}
for(k = 0; k < i; k ++)
printf("%c",s2[k]);
for(k = 0; k < i; k ++)
{
for(j = 0; j < 26; j ++)
if(s2[k]==s1[j])
printf("%c",j+'a');
}
printf("\n");
}
}
return 0;
}
Clairewd’s message
最新推荐文章于 2020-10-09 17:49:58 发布