SDUT--数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

示例代码如下:

#include <bits/stdc++.h>

using namespace std;

struct node
{
    int data;
    struct node *next;
} *head, *p, *q, *tail;

int main()
{
    int N;
    while(~scanf("%d", &N))
    {
        head = (struct node *)malloc(sizeof(struct node));
        head->next = NULL;
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = head->next;
        head->next = p;
        N--;
        while(N--)
        {
            p = (struct node *)malloc(sizeof(struct node));
            p->next = NULL;
            scanf("%d", &p->data);
            tail = head;
            q = head->next;
            while(q)
            {
                if(p->data < q->data)
                {
                    p->next = tail->next;
                    tail->next = p;
                    break;
                }
                else if(p->data >= q->data && q->next == NULL) // 来处理大于等于当前数据的元素
                {
                    p->next = q->next;
                    q->next = p;
                    break;
                }
                tail = q;
                q = q->next;
            }
        }
        p = head->next;
        while(p)
        {
            printf("%d%c", p->data, p->next?' ':'\n');
            p = p->next;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WMYBlog

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值