HDU 3819 A and B Problem

A and B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 786    Accepted Submission(s): 251


Problem Description
After calculating A + B, let’s consider another easy problem which only contains A and B.
You are given a string s containing only the letters 'A' and 'B'. The letters are arranged in a circle, so the last and first characters are adjacent. You will perform a series of swaps until all the 'A's form one consecutive sequence and all the 'B's form another consecutive sequence. In each swap, you can select any two characters and swap them. Find the minimal number of swaps necessary to reach your goal.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case only contains a string as description.

Technical Specification

1. 1 <= T <= 100
2. 1 <= |S| <= 100000, |S| indicating the length of the string.
 

Output
For each test case, output the case number first, then the minimal number of swaps.
 

Sample Input
  
  
3 AABB ABAB AABABA
 

Sample Output
  
  
Case 1: 0 Case 2: 1 Case 3: 1
 

Author
iSea@WHU
 

Source
可以用循环数组也可以直接扩展成两倍计算。只需要选择一个范围,我们让这个范围大小是A的个数,一格一格的移动过去,判断所有情况中这个范围内B的个数最少是多少,这个就是需要移动的最少的次数了。
#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
string s,t;
int main(){
	int n;
	scanf("%d",&n);
	int zl = 1;
	while(n--)
	{		
		cin >> s;
		int cnta = 0;
		int cnt = 0;
		for (int i = 0; i < s.size(); i++)
		{
			if (s[i] == 'A') cnta++;
		}
		t = s + s;
		for (int i = 0; i < cnta; i++)
		{
			if (t[i] == 'B') cnt++;
		}
		int end = cnta -1;
		int min_cnt = cnt;
		for (int i = 1; i < s.size(); i++)
		{
			if (t[i - 1] == 'B') cnt--;
			if (t[end + 1] == 'B') cnt++;
			end++;
			min_cnt = min(cnt,min_cnt);
		}
		printf("Case %d: %d\n",zl++,min_cnt);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值