1004. Counting Leaves (30)
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input2 1 01 1 02Sample Output
0 1
题意:给出一棵树的非叶子结点和它的子节点,然后求这棵树每层的叶子节点数。
思路:我的想法是先从根节点搜索并依次算出每个节点所在层数再算每层的叶子节点数目。
#include<iostream>
#include<cstring>
using namespace std;
int cnt[110],maxh;
class Node
{
public:
int num,height;
int child[110];
}node[110];
void dfs1(int pos)
{
if(node[pos].num==0) return;
for(int i=0;i<node[pos].num;i++)
{
node[node[pos].child[i]].height=node[pos].height+1;
if(node[node[pos].child[i]].height>maxh) maxh=node[node[pos].child[i]].height;
dfs1(node[pos].child[i]);
}
return ;
}
void dfs(int pos)
{
if(node[pos].num==0)
{
cnt[node[pos].height]++;
return;
}
for(int i=0;i<node[pos].num;i++)
{
dfs(node[pos].child[i]);
}
return;
}
int main()
{
int n,m;
cin>>n>>m;
memset(node,0,sizeof(node));
memset(cnt,0,sizeof(cnt));
int i,j,k,r,t;
maxh=0;
for(i=0;i<m;i++)
{
cin>>t>>k;
node[t].num=k;
for(j=0;j<k;j++)
{
cin>>r;
node[t].child[j]=r;
//node[r].height=node[t].height+1;
//if(node[r].height>maxh) maxh=node[r].height;
}
}
dfs1(1);
dfs(1);
for(i=0;i<maxh;i++)
cout<<cnt[i]<<" ";
cout<<cnt[i]<<endl;
return 0;
}