PAT 甲级 1004. Counting Leaves(层序遍历bfs)

 

1004. Counting Leaves (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

 

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

 

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

分析:不知道是我变强了还是咋地,这题我很快就ac了,pat甲级题库的前四题是真的简单。这题唯一的难点可能是不好理解题意,加重的 for every seniority level是对每一层的意思,就是统计每一层结点中是叶子结点的个数。

 

#include<stdio.h>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	//freopen(".txt","r",stdin);
	int n,m,r[100]={0},flag=1;
	cin>>n>>m;
	vector<int>v[n+1];//用邻接表存储信息
	for(int i=0;i<m;i++){
		int num,k;
		cin>>num>>k;
		for(int j=0;j<k;j++){
			int d;
			cin>>d;
			v[num].push_back(d);
		}
	}
	queue<int>q;//bfs遍历 
	q.push(1);
	r[1]=1;
	while(!q.empty()){
		/*这里我思考了一会,题意是让统计每一层当中的叶子结点个数,如何算是一层了。
		我以前喜欢用map存储,然后想到用数组就可以了,又想了会,感觉还是有些多余,其实每次记录当前结点队列的数量,把这些结点一个个都取出来,是叶子结点就加一,不是就把他的儿子全加进来。*/
		int sum=0,size=q.size();
		for(int i=0;i<size;i++){
			int data=q.front();
				q.pop();
			if(v[data].size()==0)sum++;
			else
				for(int j=0;j<v[data].size();j++)
					q.push(v[data][j]);
		}
		if(flag){
			flag=0;
			cout<<sum;
		}
		else
			cout<<" "<<sum;	
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值