PAT (Advanced Level) Practice 1004 Counting Leaves(dfs 建立树)

Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01
The input ends with N being 0. That case must NOT be processed.

Output Specification

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

题意: 就是给你一些父亲节点和子节点,让你求出每一层叶子节点的个数,第一行给出俩个数n和m,n表示节点的个数,m表示非叶子节点的个数,接下来m行,第一个数字表示非叶子节点,第二个数字k表示这个非叶子节点有k的子节点。为了简单一点,根节点从01开始。
这个就用dfs建立树,然后记录每个节点在的哪一层。
AC代码

#include <stdio.h>

struct Node {
	int h, num;
	int child[105];
} node[105];

void dfs(int root, int height) {
	node[root].h = height;
	for(int i = 0; i < node[root].num; i++) {
		dfs(node[root].child[i], height + 1);
	}
}

int main() {
	int n, m;
	scanf("%d %d", &n, &m);
	for(int i = 0; i < m; i++) {
		int root;
		scanf("%d", &root);
		scanf("%d", &node[root].num);
		for(int i = 0; i < node[root].num; i++) scanf("%d", &node[root].child[i]);
	}
	dfs(1, 0);
	int max = 0, h[105] = {0};
	for(int i = 1; i <= n; i++) {
		if(node[i].num == 0) {
			h[node[i].h]++;
			if(max < node[i].h) max = node[i].h;
		}
	}
	printf("%d", h[0]);
	for(int i = 1; i <= max; i++) printf(" %d", h[i]);
	printf("\n");
	return 0;
}

End

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值