1013. Battle Over Cities (25)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input3 2 3 1 2 1 3 1 2 3Sample Output
1 0 0
题意:给出n个城市之间的路径,假如其中有一座城市被包围了,需要另外修多少条路使得另外的城市是连通的。
思路:典型的并查集题目,但是要注意一点,使用朴素的并查集会超时,所以需要压缩路径。
#include<iostream>
#include<iomanip>
#include<map>
#include<iterator>
using namespace std;
class Node
{
public:
int x;
double y;
};
map<int,double> node;
Node node1[110],node2[110];
int main()
{
int n,m;
int i,j,k;
cin>>n;
for(i=0;i<n;i++)
cin>>node1[i].x>>node1[i].y;
cin>>m;
for(i=0;i<m;i++)
cin>>node2[i].x>>node2[i].y;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
int r=node1[i].x+node2[j].x;
double t=node1[i].y*node2[j].y;
if(node.count(r))
{
t=t+node[r];
if(t==0) node.erase(r);
else node[r]=t;
}
else
{
node.insert(make_pair(r,t));
}
}
}
cout<<node.size();
map<int,double>::reverse_iterator it;
for(it=node.rbegin();it!=node.rend();++it)
{
cout<<" "<<it->first<<" ";
cout<<fixed<<setprecision(1)<<it->second;
}
return 0;
}