[动态规划]UVA103 - Stacking Boxes


 Stacking Boxes 

Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box tex2html_wrap_inline40 (length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes tex2html_wrap_inline44 such that each box tex2html_wrap_inline46 nests in box tex2html_wrap_inline48 ( tex2html_wrap_inline50 .

A box D = ( tex2html_wrap_inline52 ) nests in a box E = ( tex2html_wrap_inline54 ) if there is some rearrangement of the tex2html_wrap_inline56 such that when rearranged each dimension is less than the corresponding dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

Formally, we define nesting as follows: box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 oftex2html_wrap_inline64 such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., if tex2html_wrap_inline70 for all tex2html_wrap_inline72 .

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)

This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. Thetex2html_wrap_inline82 line in the sequence ( tex2html_wrap_inline84 ) gives the measurements for the tex2html_wrap_inline82 box.

There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).

In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.

The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9

Sample Output

5
3 1 2 4 5
4
7 2 5 6

题意:

在数学或电脑科学里,有些概念在一维或二维时还蛮简单的,但到N维就会显得非常复杂。试想一个 n维的「盒子」:在二维空间里,盒子( 2 , 3 )可代表一个长为2个单位,宽为3个单位的盒子;在三维空间里,盒子( 4 , 8 , 9 )则是一个4*8*9(长、宽、高)的盒子。至于在六维空间里,也许我们不清楚( 4 , 5 , 6 , 7 , 8 , 9 )长得怎样,不过我们还是可以分析这些盒子的特性。

在此问题里,我们要算出一组n维盒子里,它们的「最长套入串列」: b 1 , b 2 , ......,b k,其中每个盒子b i 都可以「放入」盒子b i+1中(1 <= i < k)

考虑两个盒子D =( d 1 , d 2 , ......,d n ), E =( e 1 , e 2 , ......,e n )。如果盒子D的n个维,能够存在一种重排,使得重排后, D每一维的量度都比E中相对应的维的量度还要小,则我们说盒子D能「放入」盒子E 。(用比较不严谨的讲法,这就好像我们将盒子D翻来翻去,看看能不能摆到E里面去。不过因为我们考虑的是任一重排,所以实际上盒子不只可转来转去,甚至还可以扭曲。)(还是看看下面的例子说明好了)。

譬如说,盒子D = ( 2 , 6 ) 能够被放入盒子E = ( 7 , 3 ) 里,因为D 可以重排变为( 6 , 2 ) ,这样子D 的每个维的量度都比E里对应的维还要小。而盒子D = ( 9 , 5 , 7 , 3 ) 就没办法放进盒子E = ( 2 , 10 , 6 , 8 ) ,因为就算再怎摸重排D 里的维,还是没办法符合「放入」的条件。不过F = ( 9 , 5 , 7 , 1 ) 就可以放入E 了,因为F 可以重排成( 1 , 9 , 5 , 7 ) ,这样就符合了放入的条件。

我们今定义「放入」如下:对于任两个盒子D =( d 1 , d 2 , ......,d n)和E =( e 1 , e 2 , ......, e n),如果存在一种1..n的重排π,使得对于任何的1 <= i <= n,皆有d π(i) < e i,则我们说盒子D能「放入」盒子E 。

思路:这是DAG图上的动态规划了,先要建立图的模型,再使用动态规划比较简单。当盒子i能放在盒子j中时则存在i到j的一条路劲。

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

int node[40][12],dp[40],path[40];
int map[40][40];
int num,tag;

int ok(int x,int y,int len)
    {
        if(node[x][0]<node[y][0])
            {
                for(int i=1;i<len;i++)
                    if(node[x][i]>=node[y][i]) return false;
                return true;
            }
        else return false;
    }

int d(int pos)
    {
        int& ans=dp[pos];
        if(ans>0) return ans;
        ans=1;
        for(int j=0;j<num;j++)
            {
                if(map[pos][j])
                    {
                        ans=max(ans,d(j)+1);
                    }
            }
        return ans;
    }

void print_ans(int i)
    {
        int j;
        if(tag) cout<<" "<<i+1;
        else{
            tag=1;
            cout<<i+1;
        }
        for(j=0;j<num;j++)
            {
                if(map[i][j]&&dp[i]==dp[j]+1)
                    {
                        print_ans(j);
                        break;
                    }
            }
    }

int main()
    {
        int len;
        while(cin>>num>>len)
            {
                memset(node,0,sizeof(node));
                memset(map,0,sizeof(map));
                memset(dp,0,sizeof(dp));
                int i,j,k;
                for(i=0;i<num;i++)
                    {
                        for(j=0;j<len;j++)
                            {
                                cin>>node[i][j];
                            }
                    }
                for(i=0;i<num;i++)
                    sort(node[i],node[i]+len);
                for(i=0;i<num;i++)
                    {
                        for(j=0;j<num;j++)
                            {
                                if(ok(i,j,len)&&i!=j) map[i][j]=1;
                            }
                    }
                int maxlen=0,cnt,pos;
                tag=0;
                for(i=0;i<num;i++)
                    {
                        cnt=d(i);
                        if(cnt>maxlen) maxlen=cnt,pos=i;
                    }
                cout<<maxlen<<endl;
                print_ans(pos);
                cout<<endl;
            }
        return 0;
    }


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值