Max Sum(dp)

Max Sum

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 29   Accepted Submission(s) : 13
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

Author

Ignatius.L 

求最大和子串,用动态规划的方法来做。令f[n]为到第n个位置时的最大和。则f[n]=max{f[n-1]+data[n],data[n]}
即如果f[n-1]+data[n]>data[n],则f[n]=f[n-1]+data.也就是f[n-1]>0。如果f[n-1]>0,则后一项加上f[n-1]肯定更大。所以本题主要求f[1..n]。然后求出f中最大的一个(max(f[1..n]))。这题又要求最大串的开始与结束位置,当f[n-1]<0时,开始位置要重新开始记录。主要思想是这样,编写的时候可以换一种实现形式。如下
#include<stdio.h>
int main()
{
 int s,e,max,sum,n,t,dat,i,s1,j;
 for (;scanf("%d",&t)!=EOF;)
 {
  j=1;
  while (t--)
  {
   max=-10000;sum=0;
   scanf("%d",&n);
   s1=1;
   for(i=1;i<=n;i++)
   {
    scanf("%d",&dat);
    sum+=dat;
    if(sum>max)
    {
     max=sum;s=s1;e=i;
    }
    if(sum<0)
    {
     sum=0;s1=i+1;
    }
   }
   if(j-1!=0) printf("\n");
   printf("Case %d:\n",j++);
   printf("%d %d %d\n",max,s,e);
   
  }
 }
 return 0;
}



动态规划写:
#include <stdio.h>
#define MAX 111111
int main()
{
int n,i;
scanf("%d",&n);
for(i=0;i<n;i++)
{
int length,j,thead,head,last,max;
int arr[MAX],res[MAX];
scanf("%d",&length);
for(j=0;j<length;j++)
scanf("%d",&arr[j]);
max=res[0]=arr[0];
head=thead=last=1;
for(j=0;j<length-1;j++)
{
if(res[j]+arr[j+1]>=arr[j+1])
{
res[j+1]=res[j]+arr[j+1];
if(res[j+1]>max)
max=res[j+1],head=thead,last=j+1+1;
}
else
{
res[j+1]=arr[j+1];
thead=j+1+1;
if(res[j+1]>max)
max=res[j+1],head=thead,last=j+1+1;
}
}
 printf("Case %d:\n",i+1);
 printf("%d %d %d\n",max,head,last);
 if(i!=n-1)  printf("\n");
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值