1030 - Image Is Everything (贪心)

Your new company is building a robot that can hold small lightweight objects. The robot will have the intelligence to determine if an object is light enough to hold. It does this by taking pictures of the object from the 6 cardinal directions, and then inferring an upper limit on the object's weight based on those images. You must write a program to do that for the robot.

You can assume that each object is formed from an N×N×N lattice of cubes, some of which may be missing. Each 1×1×1 cube weighs 1 gram, and each cube is painted a single solid color. The object is not necessarily connected.

Input 

The input for this problem consists of several test cases representing different objects. Every case begins with a line containing  N , which is the size of the object (   1$ \le$N$ \le$10 ). The next  N  lines are the different  N×N  views of the object, in the order front, left, back, right, top, bottom. Each view will be separated by a single space from the view that follows it. The bottom edge of the top view corresponds to the top edge of the front view. Similarly, the top edge of the bottom view corresponds to the bottom edge of the front view. In each view, colors are represented by single, unique capital letters, while a period ( . ) indicates that the object can be seen through at that location.

Input for the last test case is followed by a line consisting of the number 0.

Output 

For each test case, print a line containing the maximum possible weight of the object, using the format shown below.

Sample Input 

3
.R. YYR .Y. RYY .Y. .R.
GRB YGR BYG RBY GYB GRB
.R. YRR .Y. RRY .R. .Y.
2
ZZ ZZ ZZ ZZ ZZ ZZ
ZZ ZZ ZZ ZZ ZZ ZZ
0

Sample Output 

Maximum weight: 11 gram(s)
Maximum weight: 8 gram(s)

题意:给定立方体的几个视图的颜色。 '.'代表能看穿,求立方体最多几块。

思路:有'.'的那一行肯定能穿过去。但是还不够,如果两个方向看过去的颜色不一样。当前那块肯定要删掉。按照这样删到不能删为止。就是最重的。

代码:

#include <stdio.h>
#include <string.h>
const int N = 10;
int n, x, y, z;
char view[N][6][N], res[N][N][N];

void tra(int i, int j, int k, int l) {
    if (j == 0) {x = i; y = k; z = l;}
    if (j == 1) {x = i, y = l; z = n - 1 - k;}
    if (j == 2) {x = i; y = n - 1 - k; z = n - 1 - l;}
    if (j == 3) {x = i; y = n - 1 - l; z = k;}
    if (j == 4) {x = l; y = k; z = n - 1 - i;}
    if (j == 5) {x = n - 1 - l; y = k; z = i;}
}

void init() {
    for (int i = 0; i < n; i ++)
	for (int j = 0; j < n; j ++)
	    for (int k = 0; k < n; k ++)
		res[i][j][k] = '#';
    for (int i = 0; i < n; i ++)
	for (int j = 0; j < 6; j ++) {
	    for (int k = 0; k < n; k ++) {
		scanf("%c", &view[i][j][k]);
		if (view[i][j][k] == '.') {
		    for (int l = 0; l < n; l ++) {
			tra(i, j, k, l);
			res[x][y][z] = '.';
		    }
		}
	    }
	    getchar();
	}
}

int solve() {
    while (1) {
	int flag = true;
	for (int i = 0; i < n; i ++)
	    for (int j = 0; j < 6; j ++)
		for (int k = 0; k < n; k ++) {
		    if (view[i][j][k] != '.') {
			for (int l = 0; l < n; l ++) {
			    tra(i, j, k, l);
			    if (res[x][y][z] == '.') continue;
			    if (res[x][y][z] == '#')
				res[x][y][z] = view[i][j][k];
			    if (res[x][y][z] == view[i][j][k]) break;
			    res[x][y][z] = '.';
			    flag = false;
			}
		    }
		}
	if (flag) break;
    }
    int ans = 0;
    for (int i = 0; i < n; i ++)
	for (int j = 0; j < n; j ++)
	    for (int k = 0; k < n; k ++)
		if (res[i][j][k] != '.')
		    ans ++;
    return ans;

}

int main() {
    while (~scanf("%d%*c", &n) && n) {
	init();
	printf("Maximum weight: %d gram(s)\n", solve());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值