UVA 668 - Parliament(贪心构造)



  Parliament 

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.


You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input 

The first line of the input is an integer M, then a blank line followed by M datasets. There is a blank line between datasets. Each dataset contains a single integer  N  (  $5 \le N \le 1000$ ).

Output 

For each dataset, write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces. Print a blank line between datasets.

Sample Input 

1

31

Sample Output 

2 3 5 6 7 8
题意:大概就是n个人,问最多分成几个不同人数的小组(人数至少为2)如果人数相同,输出字典序最大的。

思路:贪心,找一个2 + 3 + 4..+i的序列,使得最大小于n,然后剩下人数去补全,尽量平均补,如果不能平均剩下的就从后面往前补。

代码:

#include <stdio.h>
#include <string.h>

int t, n;

int Sum(int n) {
	return (1 + n) * n / 2 - 1;
}

void solve() {
	for (int i = 2; ; i++) {
		if (Sum(i + 1) > n) {
			int sum = Sum(i);
			int tmp = (n - sum) / (i - 1);
			int k = (n - sum) % (i - 1);
			int bo = 0, j;
			for (j = 2; j <= i -  k; j++) {
				if (bo++) printf(" ");
				printf("%d", j + tmp);
			}
			for (j = i - k + 1; j <= i; j++) {
				if (bo++) printf(" ");
				printf("%d", j + tmp + 1);
			}
			printf("\n");
			break;
		}
	}
	if (t) printf("\n");
}

int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		solve();
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值