1346 - Songs (贪心)

John Doe is a famous DJ and, therefore, has the problem of optimizing the placement of songs on his tapes. For a given tape and for each song on that tape John knows the length of the song and the frequency of playing that song. His problem is to record the songs on the tape in an order that minimizes the expected access time. If the songs are recorded in the order S(s1),..., Ss(n) on the tape then the function that must be minimized is

$\displaystyle \sum^{​{n}}_{​{i=1}}$ f s(i) $\displaystyle \sum^{​{s(i)}}_{​{j=1}}$ l s(j)

where  fs(i)  is the frequency of playing the  i -th song and  l is the length of the song. Can you help John?

Input 

The program input is from a text file. Each data set in the file stands for a particular set of songs that must be recorded on a tape. A data set starts with the number N (fits a 16 bit integer) of songs. Follow N the song specifications, and in the end, a number representing the position of a song S on the optimized tape. A song specification consists of the song identifier (fits an integer), the length of the song (fits a 16 bit integer), and the frequency of playing the song (a floating-point number). The program prints the identifier of the song S .

White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output 

For each set of data the program prints the result to the standard output from the beginning of a line.


Note: An input/output sample is in the table below. There is a single data set that contains 5 song specifications. The first song has the identifier 1, length 10 and playing frequency 45.5 etc. The result for the data set is the identifier of the 3rd song on the optimized tape. It is 2 for the given example.

Sample Input 

5
1      10     45.5
2      5      20 
30     20     10 
400    50     35 
15     17     89.9
3

Sample Output 

2

题意:n张唱片,每张都有长度和频率,要求题目中公式值最小。求一个排序,输出该排序下第m张CD的id。

思路:贪心,长度越长放越后面,频率越低放越后面,所以按len/p去排序即可。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int N = 1<<16;

int n, m;
struct CD {
    int id;
    double len;
    double p;
} cd[N];

int cmp(CD a, CD b) {
    return (a.len / a.p - b.len / b.p) < 1e-9;
}

int main() {
    while (~scanf("%d", &n)) {
	for (int i = 0; i < n; i ++)
	    scanf("%d%lf%lf", &cd[i].id, &cd[i].len, &cd[i].p);
	sort(cd, cd + n, cmp);
	scanf("%d", &m);
	printf("%d\n", cd[m - 1].id);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值