uva 193 - Graph Coloring

 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

  figure22
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
uva之前几章有道类似的2色问题,那道题目是判断图能否用黑白二色,此题是黑色的最大个数
开始的做法,从起点开始穷举2种颜色,然后根据图的连通性,找到连通的点涂上与之前相反的颜色判断涂完后是否有冲突,不冲突的话dfs并记录过程中产生的最大黑色数目。tld......,不管超不超时,算法貌似错了,因为出现冲突如果是白色的还是要dfs。剪枝条件写起来也繁琐
换个做法方便多了,因为要求黑色最大数目,先全涂上白色,(不用管白色是否冲突,开始没注意黑白都判断了),依次涂上黑色如果不冲突dfs一次黑色数目+1,然后不涂黑色dfs一次黑色数目不加。记录最大的数目max,当剩下所有点均为黑色加上当前数目也无法超过max不用dfs,
#include<stdio.h>
#include<string.h>
int max,n,color[101],black[101],map[101][101];
int dfs(int x,int num)
{int i,f=1;
 if (max<num) {max=num; for (i=1;i<=n;i++) black[i]=color[i];}
 if (num+n-x+1<=max) return 0;
 for (i=1;i<=n;i++)
 if ((map[i][x]==1)&&(color[i]==1)) {f=0; break;}
 if (f) {color[x]=1; dfs(x+1,num+1); color[x]=0;}  //当前点涂黑色dfs,然后回溯。
 dfs(x+1,num);
 return 0;
}
int main()
{int t,num,i,j,k,x,y;
 scanf("%d",&t);
 while (t--)
 {
 scanf("%d%d",&n,&k);
 memset(map,0,sizeof(map));
 memset(color,0,sizeof(color));
 for (i=1;i<=k;i++)
 {scanf("%d%d",&x,&y);
  map[x][y]=1; map[y][x]=1;
 }
 max=0; num=0;
 dfs(1,0);
 printf("%d\n",max);
  for (i=1;i<=n;i++)
  if (black[i])
  {++num;  printf("%d",i);
   if (num==max) printf("\n"); else printf(" ");
  }
 }
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值