PAT Basic 1004

必须吐槽一下,现在找工作,完全好难,看你的专业非得刁难你一下,明明你知道我们的专业是干什么的,否则你也不会让我们来参加你们的面试,可是还是要问——“我觉得你的专业不是搞软件的啊”,虽然我的专业是——控制工程,但是,谁不知道研究生研究的内容是和导师相关的,既然我来应聘你这个岗位,我不可能什么都不知道吧。好吧,吐槽到此结束,还是看我的PAT1004

1004. 成绩排名 (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
package source.PTA;
import java.util.ArrayList;
import java.util.Scanner;

public class PTA1004 {
	private int number;
	class Student{
		private String name;
		private String ID;
		public String getName() {
			return name;
		}
		public void setName(String name) {
			this.name = name;
		}
		public String getID() {
			return ID;
		}
		public void setID(String iD) {
			ID = iD;
		}
		public int getScore() {
			return score;
		}
		public void setScore(int score) {
			this.score = score;
		}
		private int score;
		public Student(String name, String ID, int score)
		{
			this.name = name;
			this.ID = ID;
			this.score = score;
		}
		public String toString()
		{
			return name+" "+ID;
		}
		
	}
	private ArrayList<Student> student;
	public PTA1004(int num)
	{
		number = num;
		student = new ArrayList<Student>();
	}
	public int getNumber()
	{
		return number;
	}
	public String getStudent()
	{
		return student.toString();
	}
	public void getMaxMinStudent()
	{
		int score_max = Integer.MIN_VALUE;
		Student student_max = student.get(0);
		Student student_min = student.get(0);
		int score_min = Integer.MAX_VALUE;
		for(Student a: student)
		{
			if (a.getScore() > score_max)
			{
				score_max = a.getScore();
				student_max = a;
			}
			if(a.getScore() < score_min)
			{
				score_min = a.getScore();
				student_min = a;
			}
			
		}
		System.out.println(student_max);
		System.out.println(student_min);
			
	}

	public void getIn(String name, String ID, int score)
	{
		Student temp = new Student(name, ID, score);
		student.add(temp);
		
	}

	public static void main(String args[])
	{
		Scanner sc = new Scanner(System.in);
		int counter = 0;
		int number = sc.nextInt();
		PTA1004 test = new PTA1004(number);
		while(counter++ < number)
		{
			
			String name = sc.next();
			String ID = sc.next();
			int score = Integer.parseInt(sc.next());
		
			test.getIn(name, ID, score);
		
		}
		test.getMaxMinStudent();
	}
	

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值