poj 1026

题目

Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21650 Accepted: 5965

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

题意分析

大意上是给你一个密码表,原文和转换次数,然后输出密文。需要注意的是,原文需要和密码表一样长,如果不够长就用空格填补。

代码

Source Code

Problem: 1026 User: PaladinDu
Memory: 168K Time: 16MS
Language: C Result: Accepted
  • Source Code
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        unsigned char ca[201],db[201],*tmp[201],*p_tmp,uc_tmp_len[201],uc,uc1,i_tmp_use,n,i,j,k,*p_uc;
    
        char s[201],s_out[201];
        int t,db_use;
        while(scanf("%d",&n),n)
        {
            db_use = 0;
            i_tmp_use= 0;
            for(i = 1;i <=n;++i)scanf("%d",&ca[i]);
            for(i=1;i<=n;++i){
                if(ca[i]==0)continue;
                uc_tmp_len[i_tmp_use] =0;
                p_uc = uc_tmp_len+i_tmp_use;
                p_tmp = tmp[i_tmp_use] = db+db_use;
                p_tmp[(*p_uc)++] = i;
                j = i;
                while(ca[j]!=i&&ca[j]!=0){
                    p_tmp[(*p_uc)++]=ca[j];
                    k = ca[j];
                    ca[j]=0;
                    j = k;
                }
                db_use += *p_uc;
                ++i_tmp_use ;
                ca[j] = 0;
            }
            while(scanf("%d",&t),t)
            {
                gets(s);
                for(j=strlen(s+1);j<=n;++j)s[j+1]=' ';
                s[n+1]='\0';
                for(i=0;i<i_tmp_use;++i)
                {
                    p_tmp = tmp[i];
                    uc = uc_tmp_len[i];
                    k = t%uc;
                    uc1 = uc-k;
                    for(j=0;j<uc1;++j,++k)s_out[p_tmp[k]]=s[p_tmp[j]];
                    k=0;
                    for(;j<uc;++j,++k)s_out[p_tmp[k]]=s[p_tmp[j]];
                }
                s_out[n+1]='\0';
                printf("%s\n",s_out+1);
            }
            printf("\n");
        }
        return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值