poj 1029

题目

False coin
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18579 Accepted: 5226

Description

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan. 
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded. 
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings. 

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting: 
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan, 
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan, 
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan. 

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

题意分析

找到假的硬币编号,找不到则输出0

代码

Source Code

Problem: 1029 User: PaladinDu
Memory: 164K Time: 0MS
Language: C++ Result: Accepted
  • Source Code
    #include <stdio.h>
    #include <math.h>
    int main()
    {
        int N,pi,i;
        char K,C[10];
        char c[2001]={0};
        short int l[1001];
        short int r[1001];
        short int *p_l=l,*p_r=r,*p_t;
        char max_value=0;
        short int fc_index=0;
        short int uk=0;
        char i_d=0;
        scanf("%d %d",&N,&K);
        while(K-- >0)
        {
            scanf("%d",&pi);
            p_t=p_l;
            for(i = 0;i < pi;++i)scanf("%d",p_t++);
            p_t=p_r;
            for(i = 0;i < pi;++i)scanf("%d",p_t++);
    
            scanf("%s",C);
            switch (C[0]) {
            case '>':
                p_t = p_l;
                p_l = p_r;
                p_r = p_t;
            case '<':
    
                p_t=p_l;
                for(i = 0;i < pi;++i,++p_t)if(c[*p_t]!=101){if(c[*p_t]>=0)++c[*p_t];else c[*p_t]=101;}
                p_t=p_r;
                for(i = 0;i < pi;++i,++p_t)if(c[*p_t]!=101){if(c[*p_t]<=0)--c[*p_t];else c[*p_t]=101;}
                if(i_d==0)for(i=0;i<N;++i)if(c[i]==0)c[i]=101;
                ++i_d;
                break;
    
            case '=':
                for(i = 0;i < pi;++i)c[p_l[i]]=101;
                for(i = 0;i < pi;++i)c[p_r[i]]=101;
                break;
            default:
                break;
            }
        }
        for(i =1;i<=N;++i)
        {
            if(c[i]==101)continue;
            if(c[i]>0&&c[i]>max_value){fc_index = i;max_value=c[i];uk=0;}
            else if(c[i]<0&&-c[i]>max_value){fc_index=i;max_value=-c[i];uk=0;}
            else if(abs(c[i])==max_value)
            {
                if (max_value ==0 && fc_index==0)fc_index=i;
                else uk=1;
            }
        }
        if(uk==1)printf("0\n");
        else printf("%d\n",fc_index);
        return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值