ZOJ 3726 Alice's Print Service(二分)

Alice’s Print Service
Time Limit: 2 Seconds Memory Limit: 65536 KB
Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105). The second line contains 2n integers s1, p1, s2, p2, …, sn, pn (0=s1 < s2 < … < sn ≤ 109, 109 ≥ p1 ≥ p2 ≥ … ≥ pn ≥ 0). The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1…n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 … qm (0 ≤ qi ≤ 109) are the queries.

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input
1
2 3
0 20 100 10
0 99 100
Sample Output
0
1000
1000

题意

打印店有n个区间,在每个区间内有一个打印价钱即
要打印的张数在 [ s 1 , s 2 ) [s_1, s_2) [s1,s2)内价钱为 p 1 p_1 p1,在 [ s 2 , s 3 ) [s_2, s_3) [s2,s3)内价钱为 p 2 p_2 p2,当大于等于 s n s_n sn时价钱为 p n p_n pn,题目保证 s i + 1 &gt; = s i s_{i+1}&gt;=s_i si+1>=si p i &gt; = p i + 1 p_i&gt;=p_{i+1} pi>=pi+1
有m次询问,每次询问有一个要打印的总数,求每次询问打印q张所需要的最小费用

思路

首先要知道q在哪一个 s i ∼ s i + 1 s_i\sim s_{i+1} sisi+1内,所以直接二分就可以了找到这个区间就可以了,但是有可能往后面买更多的话反而比较便宜,所以我们可以从最后往前扫一遍,如果前一个的花费比后一个要大,那直接买下一个的张数就可以了,我们弄一个数组,从后扫存两个乘积的较小值就可以了,然后比较一下只买q张和买后面的张数哪个更优就可以了

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int N=1e5+5;
long long p[N];
long long s[N];
long long sum[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%lld%lld",&s[i],&p[i]);
            sum[i]=s[i]*p[i];
        }
        for(int i=n-1;i>=0;i--)
        {
            if(sum[i-1]>sum[i])
                sum[i-1]=sum[i];
        }
        p[n]=1e9;
        s[n]=1e9;
        for(int i=0;i<m;i++)
        {
            long long x;
            scanf("%lld",&x);
            int pos=upper_bound(s,s+n,x)-s;
            long long ans=min(p[pos-1]*x,sum[pos]);
            if(pos==n)
                ans=x*p[n-1];
            printf("%lld\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值