Alice‘s Print Service(二分,思维)

传送门
Problem Description
Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , …, sn, pn (0=s1 < s2 < … < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ … ≥ pn ≥ 0)… The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1…n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 … qm (0 ≤ qi ≤ 109 ) are the queries.

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input
1
2 3
0 20 100 10
0 99 100

Sample Output
0
1000
1000
题意:打印不同的张数对应一个价格,但可能多打印一些更便宜
m次询问,找到每次打印最小花费

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <vector>
#include <math.h>
#include <map>
#include <queue>
#include <set>
using namespace std;
typedef long long ll;
const int N=1e5+50;
const ll inf=0x3f3f3f3f3f3f3f3f;
set<int>q;
int t,n,m;
ll a[N],b[N];
ll s[N];
int main()
{
    //freopen("in.txt","r",stdin);
    cin>>t;
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            scanf("%lld%lld",&a[i],&b[i]);
            s[i]=a[i]*b[i];
        }


        ll mi=inf;
        for(int i=n;i>=1;i--){
            mi=min(mi,s[i]);
            s[i]=mi;
        }

        ll x;
        while(m--){
            scanf("%lld",&x);
            if(x>=a[n])
                printf("%lld\n",x*b[n] );
            else
            {
            int loc=lower_bound(a+1,a+n+1,x)-a;//在a数组中找到第一个大于等于x的值,返回它的地址
            ll ans=min(b[loc-1]*x,s[loc]);
            printf("%lld\n", ans);
           }
        }

    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值