A.Eming(13.7.7)

A.Eming

   

   Eming is a contest hold by WHUACM trainingteam. The aim is to select new members of the team.

   Usually, the first problem is a very simpleproblem such as “a+b problem”. But this time, Xioumu is tired of this kind of problem,he decide to solve “a and b problem”.

   Give you the result of a + b and a^2 – b^2,please output the result of a and b.

 

   Input

   There are several test cases. For each casethere are two double numbers indicating a+b and a^2-b^2. You may assume that a+bwill not be zero.

 

   Output

   For each case please output the result of aand b in one line, rounded to 2 decimal places.

 

   SampleInput

   3 -3

 

   SampleOutput

   1.00 2.00

这个题目就是给了a,b的关系,求出a,b的值,通过简单的数学推导,就可以得到a,b的通式,然后用C++写出来,注意语法错误即可

代码:

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
	double c,d,a,b;
	while(cin>>c>>d){
		a=(d+c*c)/(2*c);
		b=c-a;
		cout<<setiosflags(ios::fixed)<<setprecision(2)<<a<<" "<<b<<endl;
	}
	return 0;
}
		
输出是注意输出格式和保留小数个数,基本没什么问题

  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值