hdoj 1686Oulipo (简单KMP匹配)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3612    Accepted Submission(s): 1428


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
  
  
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
  
  
1 3 0
 

Source
 


一开始WA了一次,因为没有看清楚数组的大小。后来又RE了一次,因为用KMP算法,但在主串上有一次往后移动。(肯定会STACK-OVERFLOW);


#include<stdio.h>

#include<string.h>


int next[10005];
void Get_next( char* pat)
{
    int j=0;
    int k=-1;
    next[0]=-1;
    while(j<strlen(pat))
    {
        if(-1==k || pat[j]==pat[k])
        {
             ++k;
             ++j;
             if(pat[j]!=pat[k])
                next[j]=k;
             else
                next[j]=next[k];
        }
        else
           k=next[k];
    }
    j=0;
}//O(n)


int KMP_Match(char *pat, char *s)
{
    int lena,lenp,j=0,i=0;
    int ans=0;
    lenp=strlen(pat);
    lena=strlen(s);
    Get_next(pat);
    while(i<lena)
    {
        while(i<lena && j<lenp)
        {
            if(s[i]==pat[j] || -1==j)
            {
                ++i;
                ++j;
            }
            else
                j=next[j];
        }
        if(j==lenp)
        {
            ++ans;
            j=next[j];//在这里,可以看做是当模式串和主串相匹配时,最后一个字符失配,然后再一次循环下去就可以了。
        }
    }
    return ans;
}


int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        char str1[10001],str2[1000001];
        int counter=0;
        scanf("%s%s",str1,str2);
        counter=KMP_Match(str1, str2);
        printf("%d\n",counter);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值