Oulipo
题目链接
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题目翻译
题目大概意思就是输入t组数据,每组数据输入两个字符串
判断第一个字符串在第二个字符串中出现了几次,如果出现一次就从先从出现的最后一个字符重新开始判断,比如
AZA和AZAZAZA,第一次出现AZA后再从A开始,剩下的为AZAZA所以最后为3
题目分析
字符串匹配判断可用KMP,就是对字符串进行标号,比如BAPC中next1函数中就是0 0 0 0相当于没有重复出现的字符就都是0. AZA的next1函数就0 0 1
代码实现
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<map>
#include<set>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<math.h>
using namespace std;
typedef long long int ll;
const int N = 50005;
char a[1000005];//a为第二个大字符串
char b[10005];//b为第一个小字符串
int next1[10005];
int l1,l2;
void getnext(char *b)//获取next1数组值
{
int i=0,j=-1;
next1[0]=-1;
while(i<l2)
{
if(j==-1||b[i]==b[j])//如果有相同的字符或者j为-1
{
i++,j++;
next1[i]=j;
}
else
j=next1[j];
}
}
int kmp(char *a,char *b)
{
int i=0,j=0,cnt=0;
getnext(b);
while(i<l1)
{
if(j==-1||a[i]==b[j])
{
i++,j++;
}
else
j=next1[j];
if(j==l2)
//前面跟getnext()一样就是多了一个这个,如果j符合的个数为b字符串的长度就是找到了
{
cnt++;
j=next1[j];
}
}
return cnt;
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>b>>a;
l1=strlen(a),l2=strlen(b);
int res=kmp(a,b);
cout<<res<<endl;
}
return 0;
}