uva 442 Matrix Chain Multiplication(模拟)

942 篇文章 2 订阅
232 篇文章 0 订阅

 Matrix Chain Multiplication 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.



Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125


题目大意:输入n为矩阵个数,接下来n行分别为每个矩阵的行数和列数。然后是是表达式,根据表达式求解矩阵相乘的运算量大小。(不需要考虑最有问题,题目所给数据已经规定好计算顺序)


解题思路:将每个括号内的部分看作一个整体,即为新的一个矩阵(行为首矩阵的行,列为末矩阵的列),将问题分解成子问题,通过递归调用求解,用一个全局变量记录总的计算量。


#include<iostream>
#include<string.h>
using namespace std;

#define N 10000
#define M 30

struct sq{
	int l;
	int w;
}re[M];

//变量。
char name[M];				
int cnt;
int bo;
char *move;
int n;

//函数声明。
sq count();				
sq find(char c);		//根据矩阵名找到矩阵;

int main()
{
	char str[N];

	while(cin>>n)
	{	//Init.
		memset(name,0,sizeof(name));

		//Read sq.
		for(int i = 0;i < n; i++)
			cin>>name[i]>>re[i].l>>re[i].w;

		//Read and count.
		while(cin>>str)
		{
			str[strlen(str)+1]='\0';
			move=str;
			cnt=0;
			bo=1;

			count();

			if(bo)
				cout<<cnt<<endl;
			else
				cout<<"error"<<endl;
	
			memset(str,0,sizeof(str));
		}

		
	}
	return 0;}

sq count()
{
	sq dis[2];					//记录当前计算域中的矩阵。
	sq now;
	int t=0;					//记录总数。

	now.l=now.w=0;				

	while(1)
	{	
		if(*move=='\0')	
			break;
		else if('(' == *move)
		{
			move++;
			dis[t++]=count();
			if(!bo)	return now;
		}
		else if(')' == *move)
		{
			move++;
			break;
		}
		else
		{	
			dis[t++]=find(*move);
			move++;
			if(!bo)	return now;
		}
	}
	
	if(t==2)
	{	
		if(dis[0].w!=dis[1].l)	
		{
			bo=0;
			return now;
		}

		cnt=cnt+dis[0].l*dis[0].w*dis[1].w;
	}
	else if(t == 1)	return now;

	now.l=dis[0].l;
	now.w=dis[t-1].w;					//无论表达式如何计算,所得矩阵不变。
	return now;
}

sq find(char c)
{
	for(int i = 0;i < n; i++)
		if(c == name[i])	
			return re[i];

	bo=0;
	sq now;
	now.l=now.w=0;
	return now;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值