第八十五题 UVa422 Matrix Chain Multiplication

116 篇文章 1 订阅
95 篇文章 1 订阅

Suppose you have to evaluate an expression like ABCDE where A,B,C,D and E are matrices.
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary.
However, the number of elementary multiplications needed strongly depends on the evaluation order
you choose.
For example, let A be a 5010 matrix, B a 1020 matrix and C a 205 matrix. There are two
different strategies to compute A
BC, namely (AB)C and A(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed
for a given evaluation strategy.
Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 ≤ n ≤ 26), representing the number of
matrices in the first part. The next n lines each contain one capital letter, specifying the name of the
matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }
Line = Expression
Expression = Matrix | “(” Expression Expression “)”
Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”
Output
For each expression found in the second part of the input file, print one line containing the word ‘error’
if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one
line containing the number of elementary multiplications needed to evaluate the expression in the way
specified by the parentheses.
Sample Input
9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output
0
0
0
error
10000
error
3500
15000
40500
47500
15125

本来以为什么矩阵乘法,怎么放到数据结构的题里面了,原来是需要用到 栈
对于一个序列 碰到字母压栈 碰到一个 ‘)’ 弹出两个栈顶,计算,并检查是否合法
具体见代码

【题目大意】
每行的字母是一个矩阵的代号 后面两额数代表该矩阵的行数和列数
对于每个字符串 按照顺序计算算完所有的矩阵乘法一共需要做多少次乘法 不合乎矩阵乘法规则的输出error

#include<iostream>
#include<cstring>
#include<cstdio>
#include<utility>
#include<stack>
#define Maxn 10005
using namespace std;
int col[Maxn],row[Maxn];
typedef pair <int,int> pir;
char s[Maxn];
int main(int argc,char* argv[]) {
	int n; char ch;
	while(scanf("%d",&n) == 1)  {
		for(int i=1; i<=n; i++) {
			cin >> ch;
			scanf("%d %d",&row[ch - 'A'],&col[ch - 'A']);
		}
		while(scanf("%s",s) == 1) {
			int len = strlen(s);
			if(len == 1) { printf("0\n"); continue; }
			stack<pir> st; bool flag = 0;
			long long Ans = 0;
			for(int i=0; i<len; i++) {
				if(isalpha(s[i])) st.push(make_pair(row[s[i] - 'A'],col[s[i] - 'A']));
				else if(s[i] == ')') {
					pir p1 = st.top(); st.pop();
					pir p2 = st.top(); st.pop();
					swap(p1,p2);// 不进行swap的话 p1实际上是序列中右边的矩阵  但是矩阵乘法不满足交换律 
					if(p1.second == p2.first) {
						Ans += p1.first * p2.second * p2.first;
						p1.second = p2.second;
						st.push(p1);
					}
					else {
						printf("error\n");
						flag = 1;
						break;
					}
				}
			}
			if(!flag) printf("%lld\n",Ans);
		}
	}
	
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值