uva 10494 If We Were a Child Again(高精度与低精度求模和商)

737 篇文章 0 订阅

If We Were a Child Again

Input: standard input
Output: standard output

Time Limit: 7 seconds

 

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

 

 

The Problem

 

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

 

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

 

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

 

 
Output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

 

 
 
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

 

 

 

 

 
 
Sample Output

1

9

1

2147483646

 

题目大意:求高精度与低精度的模或商。

解题思路:模拟除法和模。(注意消除前导0的时候要考虑数值为0 的情况)

#include<iostream>
#include<string.h>
#include<stdlib.h>
using namespace std;

#define N 1005

struct bign{
	int len, s[N];
    
	bign(){
		memset(s, 0, sizeof(s));
		len = 1;
	}
    
	bign operator = (const char *num){
		len = strlen(num);
		for (int i = 0; i < len; i++)
			s[i] = num[i] - '0';
		return *this;
	}
    
	long long operator % (int k){
		long long sum = 0;
		for (int i = 0; i < len; i++){
			sum = sum * 10 + s[i];
			sum = sum % k;
		}
        
		return sum;
	}
    
    bign operator / (int k){
		bign sum;
		sum.len = 0;
		long long num = 0;
		for (int i = 0; i < len; i++) {
			num = num * 10 + s[i];
			sum.s[sum.len++] = num / k;
			num = num % k;
		}
		return sum;
	}
    
};

int main(){
	char str1[N], c;
	long long num2;
	while (cin >> str1 >> c >> num2){
        
		bign num1;
        
		num1 = str1;
        
		if (c == '/'){
			bign sum = num1 / num2;
			int bo = 0;
			for (int i = 0; i < sum.len; i++){
				if (bo || sum.s[i]){
					bo = 1;
					cout << sum.s[i];
				}
			}
			if (bo ==0)
				cout << bo;
			cout << endl;
		}
		else if (c == '%'){
			long long sum = num1 % num2;
			cout << sum << endl;
		}
        
		memset(str1, 0, sizeof(str1));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值