HDU - 4198 Quick out of the Harbour (BFS+优先队列)

Description

Captain Clearbeard decided to go to the harbour for a few days so his crew could inspect and repair the ship. Now, a few days later, the pirates are getting landsick(Pirates get landsick when they don't get enough of the ships' rocking motion. That's why pirates often try to simulate that motion by drinking rum.). Before all of the pirates become too sick to row the boat out of the harbour, captain Clearbeard decided to leave the harbour as quickly as possible.
Unfortunately the harbour isn't just a straight path to open sea. To protect the city from evil pirates, the entrance of the harbour is a kind of maze with drawbridges in it. Every bridge takes some time to open, so it could be faster to take a detour. Your task is to help captain Clearbeard and the fastest way out to open sea.
The pirates will row as fast as one minute per grid cell on the map. The ship can move only horizontally or vertically on the map. Making a 90 degree turn does not take any extra time.
 

Input

The first line of the input contains a single number: the number of test cases to follow. Each test case has the following format:
1. One line with three integers, h, w (3 <= h;w <= 500), and d (0 <= d <= 50), the height and width of the map and the delay for opening a bridge.
2.h lines with w characters: the description of the map. The map is described using the following characters:
―"S", the starting position of the ship.
―".", water.
―"#", land.
―"@", a drawbridge.
Each harbour is completely surrounded with land, with exception of the single entrance.
 

Output

For every test case in the input, the output should contain one integer on a single line: the travelling time of the fastest route to open sea. There is always a route to open sea. Note that the open sea is not shown on the map, so you need to move outside of the map to reach open sea.
 

Sample Input

    
    
2 6 5 7 ##### #S..# #@#.# #...# #@### #.### 4 5 3 ##### #S#.# #@..# ###@#
 

Sample Output

    
    
16 11
 

Source

BAPC 2011

题意:求走出地图的最短时间,'#'不能走,'.'耗时一,'@'耗时K+1

思路:在BFS的基础上加上优先队列

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN = 510;

struct Point {
	int x, y, step;
	bool operator< (Point const &a) const {
		return step > a.step;
	}
} st, ed;
char map[MAXN][MAXN];
int vis[MAXN][MAXN];
int dx[4]={1, -1, 0, 0};
int dy[4]={0, 0, 1, -1};
int n, m, k;

void bfs() {
	memset(vis, 0, sizeof(vis));
	priority_queue<Point> q;
	vis[st.x][st.y] = 1;
	q.push(st);
	while (!q.empty()) {
		Point cur = q.top();
		q.pop();
		if (cur.x == 0 || cur.x == n-1 || cur.y == 0 || cur.y == m-1) {
			printf("%d\n", cur.step+1);
			return;
		}
		for (int i = 0; i < 4; i++) {
			int nx = cur.x + dx[i];
			int ny = cur.y + dy[i];
			if (vis[nx][ny] || map[nx][ny] == '#')
				continue;
			if (nx >= 0 && nx < n && ny >= 0 && ny < m) {
				vis[nx][ny] = 1;
				Point tmp;
				if (map[nx][ny] == '.') {
					tmp.x = nx, tmp.y = ny;
					tmp.step = cur.step + 1;
				}
				else if (map[nx][ny] == '@') {
					tmp.x = nx, tmp.y = ny;
					tmp.step = cur.step + k + 1;
				}
				q.push(tmp);
			}
		}
	}
}


int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d%d", &n, &m, &k);
		for (int i = 0; i < n; i++) {
			scanf("%s", map[i]);
			for (int j = 0; j < m; j++) {
				if (map[i][j] == 'S') {
					map[i][j] = '.';
					st.x = i, st.y = j, st.step = 0;
				}
			}
		}
		bfs();

	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值