POJ - 2886 Who Gets the Most Candies? (反素数+线段树)

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ KN) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 

题意:N个孩子顺时针坐成一个圆圈且从1到N编号,每个孩子手中有一张标有非零整数的卡片。第K个孩子先出圈,如果他手中卡片上的数字A大于零,下一个出圈的是他左手边第A个孩子。否则,下一个出圈的是他右手边第(-A)个孩子。第p个出圈的孩子会得到F(p)个糖果,F(p)为p的因子数。求得到糖果数最多的是哪个孩子及得到多少糖果。

思路:因为数据量很大,所以我们无法模拟,那么线段树有一种计算相对位置的应用,所以我们采用线段树,还有就是我们怎么求最大的约数个数的是那个,这个就要通过

反素数:对于任何正整数x,其约数的个数记做g(x).例如g(1)=1,g(6)=4.如果某个正整数x满足:对于任意i(0<i<x),都有g(i)<g(x),则称x为反素数.

 最大约数个数的证明:在x以内,g(x)最大,在大于x小于n之间不存在因子数大于g(x)的数。假设存在p,使g(p)>g(x),则p就是n以内的最大反素数,与x使最大反素数矛盾,顾不存在p。

还有就是相对位置的移动这个比较难思考:因为我们要求余所以我们现将k减一,再加一来排除相对位置0的可能;当移动的数val>0的时候,因为他的消失会影响到后面的相对于第一个的位置,所以我们需要减一,而val<0,并不会影响到

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define lson(x) ((x) << 1)
#define rson(x) ((x) << 1 | 1)
using namespace std;
const int maxn = 500005;

char name[maxn][11];
int val[maxn];
int a[37]={1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,500001};  
int b[37]={1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,1314521};  

struct Node {
	int l, r, sum;
} node[maxn<<2];

void build(int l, int r, int rt) {
	node[rt].l = l;
	node[rt].r = r;
	node[rt].sum = r - l + 1;
	if (l == r)
		return;
	int m = l + r >> 1;
	build(l, m, lson(rt));
	build(m+1, r, rson(rt));
}

int query(int num, int rt) {
	node[rt].sum--;
	if (node[rt].l == node[rt].r)
		return node[rt].l;
	if (num <= node[lson(rt)].sum)
		return query(num, lson(rt));
	else query(num - node[lson(rt)].sum, rson(rt));
}

int main() {
	int n, k;
	while (scanf("%d%d", &n, &k) != EOF) {
		int cnt = 0, Max = 0, i = 0;
		while (a[i] <= n)
			i++;
		cnt = a[i-1];
		Max = b[i-1];
		build(1, n, 1);
		for (int i = 1; i <= n; i++) 
			scanf("%s%d", name[i], &val[i]);
		int idx;
		for (i = 0; i < cnt; i++) {
			n--;
			idx = query(k, 1);
			if (n == 0)
				break;
			if (val[idx] > 0)
				k = (k-1+val[idx]-1) % n + 1;
			else k = ((k-1+val[idx]) % n + n) % n + 1;
		}
		printf("%s %d\n", name[idx], Max);
	}
	return 0;
}
  




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值