UVA - 1378 A Funny Stone Game (SG定理)

Description

Download as PDF

The funny stone game is coming. There are n piles of stones, numbered with0, 1, 2,..., n - 1. Two persons pick stones in turn. In every turn, each person selects three piles of stones numberedi, j, k (i < j, j$ \leq$k and at least one stone left in pilei). Then, the person gets one stone out of pilei, and put one stone into pile j and pile k respectively. (Note: ifj = k, it will be the same as putting two stones into pilej). One will fail if he can't pick stones according to the rule.

David is the player who first picks stones and he hopes to win the game. Can you write a program to help him?

The number of piles, n, does not exceed 23. The number of stones in each pile does not exceed 1000. Suppose the opponent player is very smart and he will follow the optimized strategy to pick stones.

Input 

Input contains several cases. Each case has two lines. The first line contains a positive integer n ( 1 $ \leq$n$ \leq$ 23) indicating the number of piles of stones. The second line contains n non-negative integers separated by blanks, S0,...Sn-1 ( 0 $ \leq$Si$ \leq$ 1000), indicating the number of stones in pile 0 to pile n - 1 respectively.

The last case is followed by a line containing a zero.

Output 

For each case, output a line in the format `` Game t:ijk". t is the case number. i, j and k indicates which three piles David shall select at the first step if he wants to win. If there are multiple groups of i, j and k, output the group with the minimized lexicographic order. If there are no strategies to win the game, i, j and k are equal to -1.

Sample Input 

4
1 0 1 100
3
1 0 5
2
2 1
0

Sample Output 

Game 1: 0 2 3
Game 2: 0 1 1
Game 3: -1 -1 -1
题意:有n堆石头,编号为0-n-1,第i堆初始有si个石头,两个游戏者轮流操作,每次可以选3堆i,j,k,使得i<j<=k,且第i堆至少还剩一个石子,然后从第i堆拿走一个石子
再往第j堆和第k堆各放一个石子(j和k可以一样),判断先手必胜还是必败,如果必胜,输出字典序最小的一个操作(i,j,k)。
思路:可以把每个石子看作是独立的游戏,然后我们从左到右重现排列成n-1,n-2.....0,这样方便我们SG状态的转移,所以我们就可以枚举每个i的后继状态sg[j]^sg[k]了,最后判断一下
操作一次后的SG值是不是为0,也就是必败
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 105;

int n, a[maxn], sg[maxn], vis[maxn];

void init() {
	for (int i = 0; i <= 23; i++) {
		memset(vis, 0, sizeof(vis));
		for (int j = 0; j < i; j++)
			for (int k = j; k < i; k++)
				vis[sg[k]^sg[j]] = 1;
		for (int j = 0; ; j++)
			if (!vis[j]) {
				sg[i] = j;
				break;
			}
	}	
}

int main() {
	init();
	int cas = 1;
	while (scanf("%d", &n) != EOF && n) {
		int ans = 0;
		for (int i = 0; i < n; i++) {
			scanf("%d", &a[i]);
			if (a[i] & 1)
				ans ^= sg[n-1-i];
		}
		printf("Game %d: ", cas++);
		if (ans == 0)
			printf("-1 -1 -1\n");
		else {
			int flag = 0;
			for (int i = 0; i < n; i++) {
				if (a[i] == 0)
					continue;
				for (int j = i+1; j < n; j++) {
					for (int k = j; k < n; k++)
						if ((ans^sg[n-1-i]^sg[n-1-j]^sg[n-1-k]) == 0) {
							printf("%d %d %d\n", i, j, k);
							flag = 1;
							break;
						}
					if (flag)
						break;
				}
				if (flag)
					break;
			}	
		}
	}
	return 0;	
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值