UVA - 11346 Probability (概率)

Description

Download as PDF

G - Probability

Time Limit: 1 sec
Memory Limit: 16MB

Consider rectangular coordinate system and point L(X,Y) which is randomly chosen among all points in the area A which is defined in the following manner: A = {(x,y) | x is from interval [-a;a]; y is from interval [-b;b]}. What is the probability P that the area of a rectangle that is defined by points (0,0) and (X,Y) will be greater than S?

INPUT:
The number of tests N <= 200 is given on the first line of input. Then N lines with one test case on each line follow. The test consists of 3 real numbers a > 0, b > 0 ir S => 0.
OUTPUT:
For each test case you should output one number P and percentage " %" symbol following that number on a single line. P must be rounded to 6 digits after decimal point.
SAMPLE INPUT:
3
10 5 20
1 1 1
2 2 0
SAMPLE OUTPUT:
 23.348371%
0.000000%
100.000000%
题意:给定a,b,s要求在[-a,a]选定x,在[-b,b]选定y,使得(0, 0)和(x, y)组成的矩形面积大于s的概率
思路:转换成x*y > s的图形面积,利用求导函数求面积的方式计算,y=s/x的导函数是y=s*lnx
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main() {
	int t;
	double a, b, s;
	scanf("%d", &t);
	while (t--) {
		scanf("%lf%lf%lf", &a, &b, &s);
		if (a * b <= s) {
			puts("0.000000%");
			continue;
		}
		if (s == 0) {
			puts("100.000000%");
			continue;
		}
		printf("%lf%%\n", 100 - (s + s * (log(a) - log(s / b))) / a / b * 100);
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值