POJ2385 Apple Catching 动态规划

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6
   题目的意思是有两颗苹果树,每分钟会有一个苹果从其中一棵掉落,为了接住苹果,当苹果下落时John必须站在那棵树下。刚开始John站在树1下,他最多在树1和树2之间来回走W次,求John最多能接住多少个苹果。
   这是个典型的背包问题,直接上代码
#ifndef HEAD
#include <stdio.h>
#include <vector>
#include <math.h>
#include <string.h>
#include <string>
#include <iostream>
#include <queue>
#include <list>
#include <algorithm>
#include <stack>
#include <map>

using namespace std;
#endif // !HEAD

int AC[2][1001];
int main()
{
#ifdef _DEBUG
	freopen("d:\\in.txt", "r", stdin);
#endif
	int n, m;
	memset(AC, 0, sizeof(AC));
	scanf("%d %d\n", &n, &m);
	int max = 0;
	for (int i = 1; i <= n;i++)
	{
		int cur;
		scanf("%d\n", &cur);
		memset(AC[i & 1], 0, sizeof(AC) / 2);
		AC[i & 1][0] = AC[(i - 1) & 1][0] + ((cur - 1) == 0 ? 1 : 0);

		for (int t = 1; t <= i && t <= m;t++)
		{
			AC[i & 1][t] = std::max(AC[(i - 1) & 1][t], AC[(i - 1) & 1][t - 1]) + ((cur - 1) == (t & 1) ? 1 : 0);
			if (max < AC[i & 1][t])
			{
				max = AC[i & 1][t];
			}
		}
	}
	printf("%d\n", max);
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值