POJ-2385 Apple Catching(动态规划)

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W

  • Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
    Output
  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.
    Sample Input
    7 2
    2
    1
    1
    2
    2
    1
    1
    Sample Output
    6
    Hint
    INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

题意:有两个苹果树,树1和树2,你站在树1下,每一秒都有苹果落下来,给你T秒中,每一秒是哪棵树下落下苹果,你最多可以移动W次,问你最多能接到多少个苹果果。

利用动态规划 dp[i][j]表示在i 秒移动了j次能接多少个苹果。
递推式为:dp[i][j] = max(dp[i-1][j-1],dp[i-1][j]);
代码如下:

#include<iostream>
#include<cstring>
#include<cmath>
#include<string>
#include<set>
#include<vector>
#include<map>
#include<algorithm>

using namespace std;
const int MAX = 1010;
const int MAX_W = 33;
int T,W;
int apple[MAX];
int dp[MAX][MAX_W];

int main(void){
    cin >> T >> W;
    for(int i=1;i<=T;++i)
        cin >> apple[i];
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=T;++i){
        for(int j=0;j<=W;++j){
            if(j == 0)  dp[i][j] = dp[i-1][j];//要考虑一直在0这棵树下的情况。
            else    dp[i][j] = max(dp[i-1][j-1],dp[i-1][j]);//
            if(j%2+1 == apple[i])//j%2+1表示现在在哪棵树下。
                dp[i][j]++;
        }
    }
 //   cout << dp[T][W] << endl;
//我们应该找到T秒对所以移动次数中最大的,而有些代码直接输出T秒移动W次的也能过,后台数据太弱了,比如3 1 1 1 1,直接输出的是2,而结果是3
    int Max = -1;
    for(int i=0;i<=W;++i){
        Max = max(dp[T][i],Max);
    }
    cout << Max << endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值