POJ 1050 To the Max

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36457 Accepted: 19143

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

 
题意:
求出所给矩阵的最大子矩阵和
 
代码:
#include<stdio.h>
#include<string.h>

int a[102][102],b[102][102];
int N;

void merge(int k)                      //将求最大子矩阵和转化为求最大子段和 分别将相邻行相加
{
	int i,j,l,m;
	memset(b,0,sizeof(b));
	for(j=0;j<N;j++)
	{
		for(i=0;i<N-k+1;i++)
		{
			m=0;
			for(l=i;m<k;l++,m++)
			{
				b[i][j]+=a[l][j];
			}
		}
	}
}

int main()
{
	int i,j,k,sum,max=-10000000;

	while(scanf("%d",&N)!=EOF)
	{
		for(i=0;i<N;i++)
			for(j=0;j<N;j++)
				scanf("%d",&a[i][j]);
		k=1;
		while(k<=N)
		{
			merge(k);
			for(i=0;i<N-k+1;i++)
			{
				sum=-1;
				for(j=0;j<N;j++)
				{
					if(sum<0) sum=b[i][j];
					else sum+=b[i][j];
					if(sum>max) max=sum;
				}
			}
			k++;
		}
		printf("%d\n",max);
	}
	return 0;
}

思路:
将求最大子矩阵和转化为求最大字段和 分别将相邻行相加
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值