Find them, Catch them
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 25909 | Accepted: 7832 |
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1 5 5 A 1 2 D 1 2 A 1 2 D 2 4 A 1 4
Sample Output
Not sure yet. In different gangs. In the same gang.
Source
题意:
有两个不同帮派
A a b表示询问成员a和b的帮派关系
D a b表示a和b在不同的帮派中
输出询问结果
代码:
# include <stdio.h>
# include <stdlib.h>
# include <string.h>
# include <math.h>
# define Max 100010
int father[Max],e[Max]; //e[i]存储成员i的敌人
int find (int a)
{
if (a!=father[a])
father[a]=find(father[a]);
return father[a];
}
int main ()
{
int t,n,m,i,a,b;
char cmd[4];
scanf ("%d",&t);
while (t--)
{
scanf ("%d%d",&n,&m);
memset (e,-1,sizeof (e));
for (i=1;i<=n;i++)
father[i]=i;
for (i=0;i<m;i++)
{
scanf ("%s%d%d",cmd,&a,&b);
if (cmd[0]=='A')
{
if (find(a)==find(b))
printf ("In the same gang.\n");
else
if (e[b]!=-1 && find(a)==find(e[b]))
printf ("In different gangs.\n");
else
printf ("Not sure yet.\n");
}
else
{
if (e[a]!=-1) //若a存在敌人
father[find(e[a])]=father[find(b)]; //b与a的敌人在同一帮派
if (e[b]!=-1) //若b存在敌人
father[find(e[b])]=father[find(a)]; //a与b的敌人在同一帮派
e[a]=b; //更新a的敌人
e[b]=a; //更新b的敌人
}
}
}
return 0;
}
思路:
并查集
敌人的敌人是朋友