hdu-2680-Choose the best route

Link:

(http://acm.hdu.edu.cn/showproblem.php?pid=2680)

Choose the best route

   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

  One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

  There are several test cases. 
  Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
  Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
  Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

  The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

 1
-1

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

解释

  这个题目比较精彩的部分就是对于多个出发点的设置,如果从出发点去找,那么会找好长时间,所以我们自然考虑到倒过来寻找,照这个图的反图
  来寻找起点,然后查询这些起点是否可以选择。

Code

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn(1000);
const int INF(0x3f3f3f3f);
int dis[maxn];
int vis[maxn];
int map[maxn][maxn];
int n, m, s;
int least;
void input()
{
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j < i; j++)
        {
            map[i][j] = map[j][i] = INF;
        }
        map[i][i] = 0;
    }
    int p, q, t;
    for (int i = 0; i < m; i++)
    {
        scanf("%d%d%d", &p, &q, &t);
        map[q][p] = min(map[q][p], t);
    }
}
void dijkstra(int src)
{
    for (int i = 1; i <= n; i++)
    {
        dis[i] = map[src][i];
        vis[i] = 0;
    }
    vis[src] = 1;
    int _min,min_loc;
    for (int i = 1; i < n; i++)
    {
        _min = INF;
        for (int j = 1; j <= n; j++)
        {
            if (!vis[j] && _min>dis[j])
            {
                _min = dis[j];
                min_loc = j;
            }
        }
        if (_min == INF)
            break;
        vis[min_loc] = 1;
        for (int j = 1; j <= n; j++)
        {
            dis[j] = min(dis[j], dis[min_loc] + map[min_loc][j]);
        }
    }
}
int main()
{
    while (scanf("%d%d%d",&n,&m,&s)==3)
    {
        input();
        int w;
        scanf("%d", &w);
        dijkstra(s);
        int from;
        least = INF;
        while (w--)
        {
            scanf("%d", &from);
            least=min(least,dis[from]);
        }
        if (least == INF)
            puts("-1");
        else
            cout << least << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值