UVa-11988-Broken Keyboard (a.k.a. Beiju Text)

11988-Broken Keyboard (a.k.a. Beiju Text)

Description

You’re typing along text with a broken keyboard. Well it’s not so badly broken. The onlyproblem with the keyboard is that sometimes the “home” key or the “end” keygets automatically pressed (internally). You’re not aware of this issue, sinceyou’re focusing on the text and did not even turn on the monitor! After youfinished typing, you can see a text on the screen (if you turn on the monitor).

In Chinese, wecan call it Beiju. Your task is to find the Beiju text.

Input

There areseveral test cases. Each test case is a single line containing at least one andat most 100,000 letters, underscores and two special characters ‘[and ‘]. ‘[meansthe “Home” key is pressed internally, and ‘] means the“End” key is pressed internally. The input is terminated by end-of-file (EOF).

Output

For each case,print the Beiju text on the screen.

Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University


Code:


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn(1e5+10);
char input[maxn];/* store input*/
char ans[maxn<<1];/*store answer*/
int left_index,right_index;
int cnt;
int start;
bool flag;
int main()
{
    while(gets(input))
    {
        /*initialize variable*/
        memset(ans,0,sizeof(ans));
        left_index = right_index = maxn;
        flag = true;
        cnt = 0;
        for(int i = 0; i < strlen(input); i++)
        {
            switch(input[i])
            {
            case '[':
                if(flag)
                {
                    flag = false;
                    start = i + 1;
                }
                else
                {
                    for(int i = 0; i < cnt; i++)
                    {
                        ans[left_index + i] = input[start + i];
                    }
                    cnt = 0;
                    start = i + 1;
                }
                break;
            case ']':
                if(flag)
                {
                    continue;
                }
                else
                {
                    for(int i = 0; i < cnt; i++)
                    {
                        ans[left_index + i] = input[start + i];
                    }
                    flag = true;
                    cnt = 0;
                }
                break;
            default:
                if(flag)
                {
                    ans[right_index++] = input[i];
                }
                else
                {
                    left_index--;
                    cnt++;
                }
                break;
            }
        }
        if(!flag && start < strlen(input))
        {
            for(int i = 0; i < cnt; i++)
            {
                ans[left_index + i] = input[start + i];
            }
        }
        puts(ans + left_index);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值