PAT_1053: Path of Equal Weight

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti.The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
备注: 从Root开始进行DFS遍历,遍历时记录path,遍历到leaf时进行和的check。最后对所有找到的path进行一个题目要求的排序即可。PS:sort函数可真好用大笑
 
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

typedef struct node
{
	int weight;
	vector<int> child;
}NODE;

NODE tree[100];

vector<vector<int>> path; //store all the resulting path
vector<int> current_path;

void FindAllPath(int given_s, int node_id)
{
	NODE current_node=tree[node_id];
	if(current_node.child.size()==0) //it is a leaf-node, check the sum
	{
		int current_sum = 0;
		for(int i=0;i<(int)current_path.size();i++)
			current_sum+=tree[current_path[i]].weight;
		if(current_sum==given_s) //found a path!
			path.push_back(current_path);
	}
	else //non-leaf,doing a recursive call
	{
		for(int i=0;i<(int)current_node.child.size();i++)
		{
			int child = current_node.child[i];
			current_path.push_back(child);
			FindAllPath(given_s,child);
			current_path.pop_back();
		}
	}
}

bool compare(vector<int> p1, vector<int> p2)
{
	int minlen=(p1.size()<p2.size())?p1.size():p2.size();
	for(int i=1;i<minlen;i++)
	{
		if(tree[p1[i]].weight>tree[p2[i]].weight)
			return true;
		else if(tree[p1[i]].weight<tree[p2[i]].weight)
			return false;
		else
			continue;
	}
	return false;
}

int main()
{
	int n_nodes,n_non_leaf,given_s;
	cin>>n_nodes>>n_non_leaf>>given_s;

	for(int i=0;i<n_nodes;i++)
		cin>>tree[i].weight;
	for(int i=0;i<n_non_leaf;i++)
	{
		int id,k;
		cin>>id>>k;
		for(int j=0;j<k;j++)
		{
			int node;
			cin>>node;
			tree[id].child.push_back(node);
		}
	}
	current_path.push_back(0);
	FindAllPath(given_s,0);

	//first we need to sort the result
	sort(path.begin(),path.end(),compare);
	for(int i=0;i<(int)path.size();i++)
	{
		vector<int> p = path[i];
		for(int j=0;j<(int)p.size();j++)
		{		
			if(j==(int)p.size()-1)
				cout<<tree[p[j]].weight<<endl;
			else
				cout<<tree[p[j]].weight<<" ";
		}
	}

	return 0;
}


 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值