poj2409 Let it Bead


Let it Bead
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4261 Accepted: 2798

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21


最近在看组合数学,发现组合数学不是想象的那么简单,有着各种技巧与公式,有时很让人难以琢磨。有时就有一点怀疑自己的智商。不多说来,说多了就是泪呀!


题意:

就是给你C种颜色,n个球,给球涂颜色,在环形中如果经过旋转可以变为其他的那这算一种。具体看题意把;

本题是一个典型的Polya定理,分为两类:

一类是:旋转得到的项链,在这种情况下的循环节是gcd(n,i),这是根据定理可以得到一个结果ans1;

另一类是:翻转问题,翻转时要注意n的奇偶性,若n为奇数此时的循环节是(n+1)/2.  当n为偶数时就有两种情况,在每个占n/2,所以循环节为n/2和n/2+1;

循环节弄好之后就好搞定了。polya定理就套公式了,|G|=2*n

(m^c(a1)+m^c(a2)+m^c(a3).......)

求出最后结果,代码:


#include<iostream>
#include<fstream>
#include<iomanip>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<sstream>
#include<cassert>
using namespace std;
#define LL __int64

int gcd(int a, int b) {
    if(b == 0) return a;
    else return gcd(b, a % b);
}


int main() {
    int m,n;
    while(cin>>m>>n) {
        if(n==0||m==0) {
            break;
        }
        int ans=0;
        for(int i=1; i<=n; i++) {
            int temp=gcd(n,i);
            ans+=pow(m+0.0,temp+0.0);
        }
        if(n%2==1) {

            ans+=n*pow(m+0.0,(n+1)/2);

        } else {
            ans+=n/2*pow(m+0.0,n/2);
            ans+=n/2*pow(m+0.0,n/2+1);
        }
        ans=ans/(2*n);
        cout<<ans<<endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值