Niven Numbers

A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a number in another base b, and a number in base b is a Niven number if the sum of its digits divides its value.

Given b (2 ≤ b ≤ 10) and a number in base b, determine whether it is a Niven number or not.


Input

You will be given a number of test cases. Each line of input contains the base b, followed by a string of digits representing a positive integer in that base. There are no leading zeroes. The input is terminated by a line consisting of 0 alone.


Output

For each case, print "yes" on a line if the given number is a Niven number, and "no" otherwise.


Sample Input

10 111
2 110
10 123
6 1000
8 2314
0

Sample Output

yes
yes
no
yes
no


Source: East Central North America 1999 Practice


my code:

#include <iostream>   
#include <string>   
using namespace std;   
int main(){   
    int base;   
    string num;      
    while (true){  
        scanf("%d",&base);   
        if (base==0) break;   
        cin>>num;
        int x=0,y=0;   
        for (int i=0;i<num.length();++i){   
            x+=num[i]-'0';   
            y=y*base+num[i]-'0';   
        }   
        if(y%x == 0)printf("yes/n");else printf("no/n");  
    }   
     
    return 0;   
}  
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值