POJ 2492(2013.9.21周赛E题:并查集)

A Bug's Life

10000ms
65536KB

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
思路:一道并查集,这题关键在如何维护每一个点到集合顶点的偏移量。第一次了解偏移量,还是挺有收获的!偏移量其实就是0和1表示是否同性还是异性。对于两个点x,y,分别找到他们的根节点fx,fy。(fx = find(x); fy = find(y);)如果fx == fy 则找到一对同性恋者,return,否者:bin[fx] = fy; fx指向fy,为了保证x和y为异性,即相对根节点的偏移量不同,fx的偏移量offset[fx] = (offset[x] + offset[y] + 1); 是同或关系,这样只对根节点操作,就不影响其它各点间的相互关系。还有:在路径压缩的过程中,采用递归形式,由根节点反向改变每个叶子节点的值,这样只用比较当前节点和他父节点之间的关系了:offset[r] = (offset[r] + offset[bin[r]]) % 2;是异或关系。
#include<stdio.h>
int bin[2005],sex[2005],ok;
int find(int x)
{
    if(bin[x]==x) return x;
    int t=find(bin[x]);
    sex[x]=(sex[x]+sex[bin[x]])%2;   //若不相等,刚改变偏移量
    bin[x]=t;     //同时并集
    return t;
}
void un(int x,int y)
{
    int a,b;
    a=find(x);   //找到从对应的数
    b=find(y);
    if(a==b)
    {
        if(sex[x]==sex[y]) {ok=1;return;}  //如果找到对应,并且性别相同
    }
    else
    {
        bin[a]=b;
        sex[a]=(sex[x]+sex[y]+1)%2;     //使根结点性别改动
    }
}
int main()
{
    int n,i,a,b,p,q,k=1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&p,&q);
        for(i=1;i<=p;i++)
        {
            bin[i]=i;
            sex[i]=0;
        }
        ok=0;
        while (q--)
        {
              scanf("%d%d",&a,&b);
              if(!ok) un(a,b);  //若找到,则输入以下的数都不用再判断了
        }
        printf("Scenario #%d:\n",k++);
        if(ok) printf("Suspicious bugs found!\n\n");
        else printf("No suspicious bugs found!\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值