HDU 1829 A Bug's Life

C - A Bug's Life
Time Limit:5000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input

     
     
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output

     
     
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!

Hint

Huge input,scanf is recommended. 
         

题目大概意思是说:一群虫子XXOO,找出有没有GAY.。
这题当时还蛮困扰我了。后来开了个数组保存几何内各个元素的对象(假设都是异性);
然后合并的时候判断一下各自的对象。
输出格式有点坑,要打空行。

#include <stdio.h>
#define N 2005
int fa[N],object[N];
int flag;
void InitSet(int n)
{
    flag=1;
    for(int i=1; i<=n; i++)
    {
        fa[i] = i;
        object[i]=0;
    }
}
int Find(int x)
{
    return fa[x] == x ? x : fa[x] = Find(fa[x]) ;
}
void Merge(int u ,int v)
{
    int fu = Find(u), fv = Find(v);
    if(fu!=fv)
    {
        if(object[fu]!=0)
            fa[object[fu]]=fv;
        if(object[v]!=0)
            fa[object[fv]]=fu;
        object[fu]=fv;
        object[fv]=fu;
    }
    else
    {
        if(fu==fv)
        {
            flag=0;
        }
    }

}

int main()
{
    int t;
    scanf("%d",&t);
    int c=1;
    while(t--)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        InitSet(n);
        int a,b;
        for(int i=0;i<k;i++)
        {
            scanf("%d%d",&a,&b);
            Merge(a,b);
        }
        printf("Scenario #%d:\n",c++);
        if(flag)
            printf("No suspicious bugs found!\n");
        else
            printf("Suspicious bugs found!\n");
        printf("\n");
    }
}

 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值