HDU 4323 编辑距离DP

Magic Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1333    Accepted Submission(s): 562


Problem Description
There are many magic numbers whose lengths are less than 10. Given some queries, each contains a single number, if the Levenshtein distance (see below) between the number in the query and a magic number is no more than a threshold, we call the magic number is the lucky number for that query. Could you find out how many luck numbers are there for each query?

Levenshtein distance (from Wikipedia http://en.wikipedia.org/wiki/Levenshtein_distance):
In information theory and computer science, the Levenshtein distance is a string metric for measuring the amount of difference between two sequences. The term edit distance is often used to refer specifically to Levenshtein distance.
The Levenshtein distance between two strings is defined as the minimum number of edits needed to transform one string into the other, with the allowable edit operations being insertion, deletion, or substitution of a single character. It is named after Vladimir Levenshtein, who considered this distance in 1965.
For example, the Levenshtein distance between "kitten" and "sitting" is 3, since the following three edits change one into the other, and there is no way to do it with fewer than three edits:
1.kitten → sitten (substitution of 's' for 'k')
2.sitten → sittin (substitution of 'i' for 'e')
3.sittin → sitting (insertion of 'g' at the end).
 

Input
There are several test cases. The first line contains a single number T shows that there are T cases. For each test case, there are 2 numbers in the first line: n (n <= 1500) m (m <= 1000) where n is the number of magic numbers and m is the number of queries.
In the next n lines, each line has a magic number. You can assume that each magic number is distinctive.
In the next m lines, each line has a query and a threshold. The length of each query is no more than 10 and the threshold is no more than 3.
 

Output
For each test case, the first line is "Case #id:", where id is the case number. Then output m lines. For each line, there is a number shows the answer of the corresponding query.
 

Sample Input
  
  
1 5 2 656 67 9313 1178 38 87 1 9509 1
 

Sample Output
  
  
Case #1: 1 0

思路:这题一看肯定是编辑距离了,以前学长教过我们方法和算法,但是那时没有学DP,所以学长把把复杂化了,刚才研究了好久,把它改成了DP的,比较简便……不过刚才小地方弄了好久,弄了2个小时了才得过,差点晕死……

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
const int M=1510;
int b[M][M];
char p[M][11],q[M][11];
int DP(char *x,char *y)
{
    int i,j,m,n,t;
	m=strlen(x);
	n=strlen(y);
    for(i=0;i<=(m>n?m:n);i++)
    {
        b[i][0]=i;
        b[0][i]=i;
    }
    for(i=1;i<=m;i++)
        for(j=1;j<=n;j++)
            if(x[i-1]==y[j-1]) b[i][j]=b[i-1][j-1]; //如果当前两个字母相等的话,编辑为0,这时就等于前一组的值了
            else
            {
                b[i][j]=min(b[i-1][j]+1,b[i][j-1]+1);
                b[i][j]=min(b[i][j],b[i-1][j-1]+1);
            }
    return b[m][n];
}
int main()
{
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,i,j,th[1505],l1,l2,sum;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%s",p[i]);
		for(i=0;i<m;i++)
		    scanf("%s%d",q[i],&th[i]);
        printf("Case #%d:\n",k++);
		for(i=0;i<m;i++)
		{
		    sum=0;
		    l1=strlen(q[i]);
			for(j=0;j<n;j++)
			{
			    l2=strlen(p[j]);
			    if(abs(l1-l2)>th[i]) continue;
			    else if(DP(p[j],q[i])<=th[i]) sum++;
			}
			printf("%d\n",sum);
		}
	}
	return 0;
}


下面是学长教的DP函数中不同的地方,虽然也是动态规划,但是学长应该是把它解释了给我们的,所以看起来有点复杂……
int DP(char *x,char *y)
{
    int i,j,m,n,t;
	m=strlen(x);
	n=strlen(y);
	for(i=0;i<m+1;i++)
        b[i][0]=i;
    for(j=0;j<n+1;j++)
        b[0][j]=j;
    for(i=1; i<m+1; i++)
        for(j=1; j<n+1; j++)
        {
            t=0;
            int min=1010;
            int c[3]={0};
            if(x[i-1]==y[j-1]) t=0;
            else t=1;
            c[0]=b[i-1][j]+1;
            c[1]=b[i][j-1]+1;
            c[2]=b[i-1][j-1]+t;
            for(int k=0; k<3; k++)
                if(min>c[k])min=c[k];
            b[i][j]=min;
        }
    return b[m][n];
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值