sdut——487-3279

    题目描述

    Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

    The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

    A, B, and C map to 2 
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 

    There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

    Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

    Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

    输入

    The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

    输出

    Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

    No duplicates.

    示例输入

    12
    4873279
    ITS-EASY
    888-4567
    3-10-10-10
    888-GLOP
    TUT-GLOP
    967-11-11
    310-GINO
    F101010
    888-1200
    -4-8-7-3-2-7-9-
    487-3279

    示例输出

    310-1010 2
    487-3279 4
    888-4567 3
    //题意:输入n个字符串,把输入的字符串转换成对应的符号,并把转换后出现次数大与1的字符串输出
    #include <iostream>
    #include <stdio.h>
    #include <map>
    #include <cstring>
    using namespace std;
    int main()
    {
    	int t;
    	char s[1007];
    	char ss[1007];
    	map<string,int>map1;
    	map<string,int>::iterator p;
    	string sss;
    	while(cin>>t)
    	{
    		while(t--)
    		{
    		    scanf("%s",&s);
    			int len=strlen(s);
    			memset(ss,0,sizeof(ss));
    			int i;
    			int j=0;
    			for(int i=0;i<len;i++)
    			{
    				if(s[i]=='A'||s[i]=='B'||s[i]=='C')
    				ss[j++]='2';
    				else if(s[i]=='D'||s[i]=='E'||s[i]=='F')
    				ss[j++]='3';
    				else if(s[i]=='G'||s[i]=='H'||s[i]=='I')
    				ss[j++]='4';
    				else if(s[i]=='J'||s[i]=='K'||s[i]=='L')
    				ss[j++]='5';
    				else if(s[i]=='M'||s[i]=='N'||s[i]=='O')
    				ss[j++]='6';
    				else if(s[i]=='P'||s[i]=='R'||s[i]=='S')
    				ss[j++]='7';
    				else if(s[i]=='T'||s[i]=='U'||s[i]=='V')
    				ss[j++]='8';
    				else if(s[i]=='W'||s[i]=='X'||s[i]=='Y')
    				ss[j++]='9';
    				else if(s[i]>='0'&&s[i]<='9')
    				ss[j++]=s[i];
    				if(j==3)
    				ss[j++]='-';
    			}
    			sss=ss;
    			map1[sss]++;
    		}
    		int max=1,flag=0;
    		for(p=map1.begin();p!=map1.end();p++)
    		{
    			if(max<p->second)
    			{
    				flag=1;
    				cout<<p->first<<" "<<p->second<<endl;
    			}
    		}
    		if(flag==0)
    		cout<<"No duplicates."<<endl;
    	
    	}
    	return 0;
    }


     
    
    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值