hdu——2586——How far away ?(lca)

Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 


Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 


Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 
Sample Input
2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1
 
Sample Output
10
25
100
100

 题意:输入n-1行a,b,c,表示a,b之间的距离为c,再输入m行a,b,表示输出a,b之间的距离

可以利用LCA,表示出a和b到根节点的距离,然后再减去2倍的公共最近祖先到根节点的距离

#include<iostream>
#include<cstring>
#include <cstdio>
using namespace std;
const int M=40005;
int head[M],father[M],vis[M],path[M];
int head1[M],dis[M];
int ans,ans1;
struct node
{
    int from;
    int to;
    int len;
    int next;
} Node[M*2];
struct node1
{
    int from;
    int to;
    int next;
    int num;
} Node1[M*2];
void init()
{
    memset(vis,0,sizeof(vis));
    memset(head,-1,sizeof(head));
    memset(head1,-1,sizeof(head1));
    for(int i=0; i<M; i++)
        father[i]=i;
}
void add(int a,int b,int c)
{
    Node[ans].from=a;
    Node[ans].to=b;
    Node[ans].len=c;
    Node[ans].next=head[a];
    head[a]=ans++;
}
void add1(int a,int b,int c)
{
    Node1[ans1].from=a;
    Node1[ans1].to=b;
    Node1[ans1].num=c;
    Node1[ans1].next=head1[a];
    head1[a]=ans1++;
}
int find(int x)
{
    if(x!=father[x])
        x=find(father[x]);
    return father[x];
}
void lca(int u)
{
    int v;
    father[u]=u;
    vis[u]=1;
    for(int i=head1[u]; i!=-1; i=Node1[i].next)
    {
        v=Node1[i].to;
        if(vis[v])
        {
            path[Node1[i].num]=find(v);
        }
    }
    for(int i=head[u]; i!=-1; i=Node[i].next)
    {
        v=Node[i].to;
        if(!vis[v])
        {
            dis[v]=dis[u]+Node[i].len;
            lca(v);
            father[v]=u;
        }
    }
}
int main()
{
    int t,n,m;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        ans=0;
        ans1=0;
        init();
        for(int i=1; i<n; i++)
        {
            int from,to,len;
            cin>>from>>to>>len;
            add(from,to,len);
            add(to,from,len);
        }
        for(int i=1; i<=m; i++)
        {
            int a,b;
            cin>>a>>b;
            add1(a,b,i);
            add1(b,a,i);
        }
        dis[1]=0;
        lca(1);
        for(int i=0; i<ans1; i+=2)
        {
            int a,b,c;
            a=Node1[i].from;
            b=Node1[i].to;
            c=Node1[i].num;
            cout<<dis[a]+dis[b]-2*dis[path[c]]<<endl;
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值